Writer misapplying border for header to footer and footer to header

I use page styles for chapters in my books. When I format the footer and apply a top border to the footer on some page styles, Writer applies the border to the footer correctly. On other page styles it applies the top border to the header for that page style instead of to the footer - even though I am formatting the footer. If I format the header on those same page styles, it applies the bottom border to the footer for that page style instead of to the header - even though I am formatting the header.

I’ve tried creating a new page style from a page style that works correctly, but the new page style doesn’t work.

You might need to post a sample couple of pages without any private text

Here is a file with 4 pages. The first page has a page style = BlankPage. The following pages page style = ProbemPage.

I’ve set simple headers and footers. The footers are the same for first page and left and right pages The header is not the same for first page or left and right pages.

When I click on the footer of the 2nd page of the file - the first ProblemPage, select Format Footer, select Borders, click to set the top border and then Apply, the top border applies to the Header of the 3rd page. (Easy to see it happen if you scroll so both the footer of 2 and header of 3 are visible when you format the footer.

Version = (x64)
Windows 10, build 19043
Dell 13 laptop
FWIW, Since posting the problem I uninstalled and reinstalled. I was able to create new page styles from the page styles that had good header and footer borders. So, I’ve worked around the problem for now.

OK I see. After you click Format Footer, you need to stay on the same tab in the page style dialog and click the More button. In the new dialog that opens you can set the style of the Footer borders.

For this sample, to get the top border, you might have to tick the box to make the footer of the first page of ProblemPages the same as the others, Apply, then untick and Apply again. Then rebuild the text in that first page.

NOTE: The Borders tab sets the borders for the page.

User error. As you said by selecting the Borders from Format Footer I was setting the borders for the page. The other page styles I did correctly by clicking the top line in the footer, selecting the Paragraph style, and changing the border there. By the time I got that far in my book I had forgotten how I did it correctly before.

Thanks for reminding me.

No worries, it happens to us all occasionally :slight_smile: