Writer Navigation Toolbar No Longer Auto-Opens in Context

I’ve just noticed a change affecting the Navigation toolbar in LO Writer. It’s handy for navigating around a longish document via the TOC or any manually added hyperlinks to sections.

With older Writer versions e.g. v6.4.7 the Navigation toolbar automatically appears in context e.g. after you click on a TOC entry, just as described in the LO Help pages.

However with v7.2.3 I’m having to invoke it manually every time I open a document, using View > Toolbars > Navigation. It’s the same result on Win 10 and Linux Mint.

Is there some setting I can adjust to bring back the original contextual opening of Navigator toolbar?

It is only short, why not have it as a permanent toolbar?
On Windows 10, LO if I click View > Toolbars > Navigation, then right click the toolbar, select Unlock Toolbar, move it next to another toolbar and Lock Toolbar then it is still there if I close LO and re-open LO. Cheers, Al


I’ve tried your suggestion to enable, unlock, move and lock the Navigation toolbar but sadly the toolbar doesn’t survive a LO restart. In fact I’ve found simply re-loading the document causes the Navigator toolbar to disappear. Hmm…

When I double-click on an entry in the index, I get the following message:

[Ctrl+click] to open the following hyperlink: Writer navigation toolbar no longer opens automatically in context.

With me:

Version: (x64) / LibreOffice Community
Build ID: d166454616c1632304285822f9c83ce2e660fd92
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

1 Like

That’s interesting. I don’t get that message on either Win 10 or Linux Mint but it is a puzzle.

I can now confirm that the message you reported is correct. The Navigation toolbar will not appear until you first enable via Menu View > Toolbars > add check to Navigation. Thereafter the Navigation toolbar always appears when you re-open Writer.

This is really a workaround until I get the time to dig deeper into the issue.
What I’ve discovered is if I start LO Writer in Safe Mode, then the Navigation toolbar behaves as it should (appears when a TOC item is Ctrl+clicked). So I think there must be something going on with my LO profile.
My workaround is to customise the toolbar “standardbar.xml” to add the Back and Forward navigation icons. That way they’re always available regardless of the context, and they don’t take up much space.
Thanks for peoples’ observations.

Resolving corruption in User Profile: LibreOffice user profile - The Document Foundation Wiki

I restarted LO 7.2.3 with a fresh configuration and then added the options and customisation I normally use. Now everything behaves as it should. Thanks for your help in identifying the root cause.
The WiKi about LO User Profile does say

Strange effects might occur, if you explicitly request a LibreOffice version to reuse a user profile from another version.

which is exactly what I had done when upgrading from v6 to v7.
One thing that is different with v6 versus v7 (and is explained by the double-click message Hrbrgr reported), is that the Navigation toolbar does not appear until you first enable via Menu View > Toolbars > add check to Navigation. Thereafter the Navigation toolbar always appears when you re-open Writer.

Other types of toolbar e.g. Table, List, Draw, appear auto-magically when you click on the appropriate object in the document.

@EarnestAl : is this corrupted profile problem on update specific to Windows? I have upgraded under Linux since LO 3.x without ever needing to reset my user profile. Is the Windows version more sensitive to this kind of issue? What could cause the behaviour difference? Some file access primitive in the OS?

@ajlittoz I had to reset my profile on Windows several times over the past few years. I don’t recall having to do it before probably version 5.
Sometimes I had to reset after upgrades, but possibly after Windows upgrades too.

I do most of my daily work on Linux Mint which is where I first observed the Navigation toolbar ‘gremlin’. Then I checked on my Win 10 laptop and found exactly the same odd behaviour, which pointed to a LO issue, as I originally copied over the Linux ‘user’ folder to Windows then simply corrected the User Paths via Menu >Tools > LO > Paths.

Like you this hasn’t been a problem until this v6 to v7 update.
Having rebuilt the user profile and copied over to Windows, both Linux and Windows are now behaving, thankfully.

Could it happen when updates skip several intermediate releases? My machine is updated nearly daily. So I always have “contiguous” release numbers without gaps, except when x or y in x.y.z.t changes. Usually my distro doesn’t offer z = 0 or 1 which are considered as “early adopters”.