Writer: Not displaying a chapter number but still counting it in the outline

I am running LibreOffice 7.5.3 on Arch Linux x86_64. The document I am editing is saved in ODT format.

Problem 1

I have the following setup in Tools > Chapter Numbering:

1 Heading 1
1.1 Heading 2

and the following headings in my document (created with the Heading n family of styles):

Abstract (heading 1, number removed)
Introduction (heading 1, number removed)
1 Methods (heading 1)
— 1.1 subpart 1 (heading 2)
— 1.2 subpart 2 (heading 2)
— …
— 1.15 subpart 15 (heading 2)

I would like to “hide” the number 1 in front of Methods, i.e. have the following outline:

— 1.1 subpart 1
— 1.2 subpart 2
— …
— 1.15 subpart 15

But if I remove the number 1, Writer gets rid of the whole chapter and subparts are numbered from 0 (0.1, …, 0.15):

0.1 subpart 1
0.2 subpart 2

0.15 subpart 15

Is there a workaround?

Problem 2

Writer adds a tab stop between the number and the title of a subchapter. For subparts 1.10 to 1.15, compared to subparts 1.1 to 1.9, the extra digit eats up some of the blank space so the number is very close to the title.

Is there a way to reduce the font size of the number without changing the font size of the title?

Here is an example (the two titles are aligned & have the same aspect ratio):


Problem 1

Usually, suppressing chapter numbering is done on parts without subdivision like Dedication, Preface or Foreword. Having unnumbered chapters with numbered sub-chapters including the chapter number is doomed to fail because you eliminate a chapter break (meaning there is no longer a point where chapter number is incremented).

I can’t diagnose your issue because you didn’t describe how you built your chapter outline. You didn’t tell if your headings were marked up as intended with Heading n family of styles. You didn’t mentioned how you numbered the headings (with Tools>Chapter Numbering or erroneously did that with some list numbering). You didn’t report how you “remove number 1”: the fact that subsequent headings are renumbered from 0 is quite unusual and betrays the fact you didn’t use the “standard” method(s). While in the lack of information, you didn’t even mention OS name, LO version and save format.

There is of course several ways to achieve it. One of them is to have a hidden standard Heading 1 chapter heading with numbering enabled. This paragraph is hidden so that it does not display. You follow it immediately with a paragraph formatted with a different paragraph style, unnumbered,. Paragraph contents is copied from the Heading 1 by a cross-reference so that you need to maintain only one copy, the text in the hidden paragraph. Of course, you attach this new paragraph style to outline level 1 so that it is collected in the TOC (while hidden paragraphs are not).

A better suggestion can be proposed if you attach a sample of your present document to your question with an edit.

Problem 2

The exact layout of chapter heading is controlled by Tools>Chapter Numbering (once again assuming you numbered your chapters with the dedicated tool and not through a manually added list numbering). You can allocate a wider space for the number by adjusting the position of the tab stop in the Position tab. It is wise to set the indent to the same distance as the tab otherwise you’ll end up with weird formatting for multi-line headings.

If you really insist on reducing font size for the number, this is also possible but it is effective on all numbers not only on those needing 2 digits. You do this in the Customize tab by selecting an appropriate Character style which you must create before customising (just set the font size, no other parameter).

When creating or reviewing a document, it is very useful to enable View>Formatting Marks to have an exact idea of what’s going on in the document.

@ajlittoz Thank you for your answer. Apologies for the missing data:

  • I’m running LibreOffice 7.5.3 on Arch Linux x86_64. The file is saved in ODT format.

  • All of my headings were created through the Heading n family of styles (note that I wrote heading 1 & heading 2 in my post, but I realize that may not have been clear).

  • I haven’t touched the list numbering settings, only Tools > Chapter numbering (as per the documentation).

  • I removed number 1 simply by entering backspace when I clicked on the heading, again as per the documentation.

I’ll try your suggested fixes ASAP and I’ll report back.

@ajlittoz Your solutions work perfectly, thank you.

Another problem I’m running into:

My document contains many bullet lists that must follow a specific format (specifically, alignment, indentation & tab stop), so I have defined a custom list style. I am using this list style with the default paragraph style, which has its Outline level set to Text Body and List style set to No List.

However, when I use my list style, it increments the chapter numbers. As above, I started with:

Abstract (Heading 1)
Introduction (Heading 1)
Methods (Heading style copied from Heading 1, which is hidden)
… 1.1 subpart 1 (Heading 2)
… 1.2 subpart 2 (Heading 2)

… 1.15 subpart 15 (Heading 2)

When I add, say, 20 lists with my list style between subparts 1.1 and 1.2, the chapter numbering is incremented as follows:

… 1.1 subpart 1
… 21.1 subpart 2

… 21.15 subpart 15

Is there a way to use my list style without having it increment chapter numbers?

(Direct formatting by clicking on the bullet list and then changing the settings as necessary works, but it is very tedious given the number of lists in my document.)

EDIT: I quit and relaunched Writer and somehow, this fixed the problem.

Your last two posts were not solutions to your initial question and shouldn’t have been entered as answers. This confuses readers, making them believe there are several alternate solutions. This site is not a forum but a Question & Answers one. There is no concept of “conversation”. The closest to it is a set of comments attached either to the question itself or to an answer, clearing identifying what is commented. Question and answers can always be edited to improve them and make them “self-sufficient”, eliminating the need to read a possibly long thread to grasp the essence of it.

Chapter and list numbering get messed up if you add some list style to Heading n. This happens if you press the toolbar button for numbering as newbies frequently do it instead of enabling numbering in Tools>Chapter Numbering. Heading n then have two numbering sequences attaches to them. The manually added one takes precedence for display. The toolbar button activates the default unnamed Format>Bullets & Numbering list style.

Attach a sample file so that I can have a look at your formatting.

Custom list style
In Writer, a list style is not a paragraph style intended to format a list. It is the definition of a numbering counter, its appearance and “geometry”. This list style must then be attached to some paragraph style, either on demand (direct formatting) or in the paragraph style configuration. This is not obvious.

I fear you defined a paragraph style and attached the default list style with the toolbar button. Once again, attach a sample file for examination.

Last remark: never use Default Paragraph Style for text in your document. Consider it an “internal technical” style. It is the ancestor of all other styles which inherit its properties. Therefore it can be used to set attributes which are shared by all others (unles overridden of course). This is very handy to change globally the font face over the whole document, for example. The standard style or text is Text Body.