Writer not responding when saving document containing images


I’ve been using LO for years without a problem. Now me and other colleagues in my company face issues while saving documents. LO gets non responsive for minutes while saving documents containing images. Here is my setup

  • LO Version:
  • Windows 7 (all latest service packs and updates as for 08.12.2013)
  • Java V
  • Lenovo T400S (with mobile intel 4 graphic chip and SSD HD)

Steps to reproduce:

  • I’ve created a clean user profil (deleting the old one)
  • I’ve created an empty writer document
  • I’ve added one line of text and clicked save…works within 1 second!
  • I’ve added one 734x35 small .jpg image and clicked save…works within 1 second!
  • I’ve added a second line of text and clicked save…works within 1 second!
  • I’ve added a second .jpg picture of 1007x365 and clicked save…Writer is “NOT RESPONDING” for ~1minute !
  • Any new attemps to save will end up in this 1 minute “not responding state”
  • If I remove the second picture, save works again within 1s.
  • Note: I’ve seen similar behaviour in Impress

What i’ve tried:

  • Copy-pasting VS inserting the pictures…no effect
  • Removing HW acceleration and/or anti-aliasing…no effect
  • Changing memory settings to 30 steps, 250mB, 10mB/object, 00:10…no effect
  • Removing the user profile and trying to save again…no effect
  • Reinstall LO from scratch, after having removed any files per hand on the HD…no effect

Guess: Is there any function trying to “resize” the pictures when while saving them ?

We cannot use LO under these circumstances and will appreciate any help!

I can send you my test file to reproduce the behaviour…



Please edit your question to provide some example files (links to JPGs) for others to test. It sounds to me like a Windows-specific issue as I cannot replicate this under GNU/Linux.

I’m now experiencing an identical issue with LO version All documents containing any image can take between 5 and 8 mins to save! Also using Windows 7, but not having issues with any other software.
Did you have any luck resolving the problem Tobias?

Hi @tobritz, have you tried changing the second picture for another of similar size?
Maybe something in this particular file is creating the issue.

Many people suffer from this bug, including me. I had been using LO for years, but since mid 2013, I got the same problem as you, using the new release(s).
What I did is: uninstall LO alltogether and installed OpenOffice, instead.

Meanwhile I also found this:

But I have not tried it.

For the information of others, the proposed solution in the linked thread was to update the video drivers.

I found this solution that resolved it for me, suggested on another site (sorry, I don’t remember where) where similar issue was posted and I decided to try it after exhausting all possibilities (antivirus, profile, different versions of Libre, graphics settings, libre settings, etc) suggested on my Windows 7 64bit OS:

Disable context indexing on the computer itself:

  1. Open Windows Explorer
  2. Right-click on the hard drive, select Properties
  3. UN-CHECK the Allow files on this drive to have contents indexed in addition to file properties
  4. Apply
  5. How long it takes to update seems to depend on amount of files on hard drive - took 20 minutes to update my
    disk which has about 600GB used on a 900+GB drive
  6. Rebooted
  7. Opened Writer, opened the file (has images and text, and issue of Not responding for 120+ seconds able to recreate on demand when select Save), added text and an image, saved.

And YES!! now Save completes immediately without long Not responding issue.

Hope this helps others.