Writer: Problems with centering text

I have spent this morning trying to resolve this issue. When I centre my heading the whole page of text centres.

First this is what my page is about. I have copied several pages of text from Grammerly and pasted into an odt. I have a title (verdana 14), an image, and 5 pages of text forming a chapter in a book. This is the fourth chapter. I have performed the same task on the previous chapters without an issue.

On the fourth chapter after pasting in the text from Grammmerly I found I could not centre the title without the whole body of the text then centres.

Obvious next action was to look on the forums in Google. I have spent this morning going patiently through the forum answers but without a resolution.

I have been through Styles and Formatting and cannot find a resolution there. I have been through the View menu without resolution. All of the fixes in the forums I have tried to apply but without result. On looking at the page showing markers and web formats I can see the correct returns in place. I can see the page breaks. I cannot see anything that looks out of place.

One thing that is strange is that if I press return in front of the first line of the chapter text then it jumps to a new page. This is also so if I press shift/return.

Any help whatsoever on clearly identifying this issue so I can work through and correct would be greatly appreciated.

Most probably you have one single paragraph, not multiple paragraphs; and the lines of this paragraph are separated by line break (which is inserted by Shift+Enter), not paragraph breaks, as usual. It must have been that way in the source you taken the text from. As the alignment is paragraph’s property, it applies to all the text from one paragraph break to the next, including all the text separated by line breaks.

Also, your paragraph mush have the manual “insert page break before” setting, which is duplicating to the following paragraph when you do insert the paragraph break.

Turn on displaying the invisible characters (CTRL+F10, but depends on OS); turn off the “insert page break before” setting on the paragraph; replace line breaks (will show up as ) with paragraph breaks (which show up as ) (if the text is not too long, it’s easy to do manually; otherwise, you could find \n and replace with the same n using regular expressions); and use paragraph styles (like Heading N) to apply formatting throughout your text.

Thanks for this support. Appreciated. I am not able to go through it now but will do later and report back. I was told last night that control/enter was also a solution to clear unwanted settings but have not seen that quoted anywhwere else.