Writer screen display goes wonky

Ever so often, in Writer, the screen display goes wonky. Text is distorted. Typically, one to three lines of so get squeezed and distorted. Sometimes, one or more lines get squeezed down to a row of dots. I’ve tried in vain to find a “refresh screen” or “refresh vies” function, but maybe I’ve just overlooked it. (The web-based help makes it MUCH, MUCH more difficult to find any useful information on the program, BTW. I’ve given up on it.)

The workaround I found by accident is to bring up the find box at the bottom of the page. Suddenly the page is displayed correctly! But this is annoying, besides being obscure.

It may be relevant that I’m normally working in very large documents, or it may not. Contents are such that I don’t want to pass on a screen shot, and it’s erratic enough that I’m not willing to take the time pretending to edit something I can pass on that way until it happens. It can be several times a day, or several days.

Happen with large documents (or with lower RAM). Don’t remember if redraw well when changing zoom (Ctrl+mouse wheel up-down).

If set, try to disable OpenGL in Tools -> Options -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use OpenGL for all rendering and check whether that fixes your problem.

If you are on macOS - you did neither mention your LibreOffice version nor your operating system - replace Tools -> Options by LibreOffice -> Preferences

Um. I’m almost always doing big documents, as I said, but the machine has all the memory it will take, and it doesn’t show symptoms of being short on memory.

I don’t know whether changing the view size would help; seem likely, but that’s at least as awkward as bringing up find, and I’d be afraid of problems getting it back where I’ve got it set. (Best compromise I can manage between my old eyes that have trouble with fine print and getting everything including comments showing at once.)

I tried disabling OpenGL. Almost immediately the problem manifested (again!). As I say, it’s kind of intermittent, so it’s hard to identify correlations, but I turned OpenGL back on.

I’m running Windows 10, and current version is But I’ve run LO on several different computers with different revs; one was a Fedora Linux machine. It’s been pretty much the same on all of them. It’s possible that it’s only since Windows upgraded to Win 10; I ran Win 7 until Microsoft forced update.

With changing zoom, I say to increase (or decrease) it momentarily, so the screen redraws.

¿Working with columns when happen?

Changing the zoom: I’ve gotten pretty good at doing ctl-F followed by escape. I can’t see that grabbing the mouse and changing the zoom, then changing it back, with attendant likelihood of overshooting sometimes, would be any improvement at all. (As it is, to get the zoom where I want it in the first place, I pop up the little window and put in the numeric value I want. Then I have to work to shift things right and left so that everything shows.)

No, I’m not using columns. I’ve done this on occasion, but not on the things I work on most of the time.

I get it occasionally (or at least used to get it), usually from rapid scrolling with the mouse on big documents. I figured that the graphics chip couldn’t keep up and that was down to hardware. My way to refresh the screen was to click in the scroll bar between the slider and the top (or bottom) once and then click on the other side of the slider to bring me back to where I was originally. Alternatively, PgDn then PgUp on keyboard. Cheers, Al