Writer: setting default font for document

I see how to see the default font for all documents but I want to set it for a document template.

I am working on a document now that asserts the system default font every time I try to enter new text.

I am creating a template. I create a font style for ‘Character’, specifying the font and size etc using the Manage Styles dialog. Call this font 'MainBody".

In the body of the template I enter a few lines of text to identify the project I am creating the template for, listing its parts – header/footer/fields etc…

I select all this text and, using the Manage Styles dialog apply the ‘Main Body’ style, save the template.

I create a document based on this template. I begin to enter text, select the entire document, apply the ‘Main Body’ style using the Manage Styles dialog.

I later go back to add a sentence into the previously entered text and find that it appears as the Writer Default Font as defined in the Tools.Options.Writer.BasicFonts.

I do not want to modify the Writer default font.I want to define a default font for the template – so that whenever new text is entered documents associated with the template then that template’s default font is used.

You seem to not using styles/templates at all, but using direct formatting and the default settings in Tools -> Options -> LibreOffice Writer -> Basic Fonts (Western). Did you change the styles using Styles -> Manage Styles or using Styles -> Edit Styles or do you just select the font from the font selection drop down in the toolbar?

Your last paragraph looks gibberish. I don’t understand what you’re doing. Please reword the paragraph, explaining with an example, such as “Text is ‘abcde’ formatted as desired, I try to type new text ‘xyz’ to get ‘abcxyzde’ and ‘xyz’ reverts to system default”.

Note that pasting text is different from typing text. Which one causes the problem?

Are you really using templates (models with .ott extension)? Have you set a specific font in the template? How? Is is different from the “system default”?

Answer editing your question.

@ajlittoz You do understand that your comment begins with an insult? Perhaps you have difficulty with the English language and if that’s the case then that’s okay. But otherwise? Your insult adds nothing of value to your comment and makes me dislike you. For no good at all.

“so that whenever new text is entered documents associated with the template then that template’s default font is used.”

It doesn’t make sense to me either. But no matter. Perhaps if you answer the questions posed by @ajlittoz , a solution to your problem might be found.

If I correctly understand the problem, you should better create/modify paragraph style(s) rather than character style(s). First of all, try modifying the Default paragraph style (many other styles will inherit modified settings).

I always have difficulty in any language when discourse is ambiguous (not abiding to grammar or containing typos like “I see how to see”). Yhis is not an insult but a fact.

Even after the update, I still don’t follow your procedure. There are many style categories in Writer. The main ones are paragraph and character. Which one are you using?

When you put the cursor somewhere in the document, text typed from there inherits the typographical attributes from the position, i.e. if a style is in effect, even if it is direct formatting, all its attributes are transmitted to fresh text. There is no way to revert to default font in Tools>Options. That’s why we need a precise description of your procedure to understand how it happens.

In case you don’t see any anomaly in your procedure, attach your document (and its template) to your question for further analysis if it is related to your styles.