'Writer' : Styles and Formating modify has stopped working

Hi All,

And thank you to all the Libre Office developers for doing what you do!


I’m working in a document with a table of contents and opened it today to change the size of Heading 1.

I used the following procedure:

Selected at random a heading which was a ‘Heading 1’ > clicked on the ‘Styles and Formatting’ icon and the right side of the screen was filled with the Styles and formatting section > right clicked Heading 1 > selected ‘Modify’ and the pop-up window titled ‘Paragraph Style: Heading 1’ appeared > I increased the size from 22 pt to 40 pt > clicked Apply but the dotted line around ‘Apply’ did not go away > clicked OK and nothing happened. The Verdana font size of Heading 1 in the document remained the same.


  • Closing and opening the file (.odt) made no difference. But upon repeating the procedure above ‘Styles & Formatting’ stated that Heading 1 was now 40 pt - except that in the document it was still at 22 pt. there are about 25 Heading 1’s in the document - they have all remained 22 pt.

  • The document was originally created in MS Word over 12 years ago. It was then changed to Apache ‘Open Office’ in about 2012. After changing to Open Office we introduced Tables of Contents. We are now attempting to go Microsoft free and have changed all computers except two to Linux Mint - and while we did it we changed from Apache to Libre.

  • Other documents created long ago in Word and which have followed the same path work fine when changing the font size of Heading 1

Can anyone help ?

Try Format>Clear direct formatting after selecting your whole Heading 1 paragraph. If that works, it means someone in the past acted manually on headings. You can get rid of this nasty beast by Edit>Select All to select whole document, then Format>Clear direct formatting. This will also clear all “embellishment” brought in outside styles. Remember that Word has no notion of character styles, so you’ll have to restore them preferentially with character styles.

Try Format>Clear direct formatting

The shortcut is Ctrl+M.

Thank you very much ajlittoz and gabix.

Your solution worked easily.

I tried the Select All option but there was a lot of manual formatting within the text which was not related to the Table Of Contents: That instantly corrected all the headings but lost a vast amount of formatting under each heading which had been built-up over the years.

So instead: > Manually selected each ‘Heading 1’ > ‘Cleared Direct Formatting’ - Voila!