Writer, Styles and Formatting

The program highlights the page style (or paragraph style) selected, but it is so dark grey it practically blocks out the name of the style selected. There must be a way to lighten that highlight, but I can’t find it.

This is a matter of “theme”. You probably selected a dark one in Finder. Try another one to see if there is a difference. If so, you can afterwards tailor LO applications colors in Preferences, LibreOffice>Personalization (LO theme) or LibreOffice>Appearance to override the offending ones.