Writer tabbed mode switches to Table tab whenever I click inside a table

When I’m editing a table in Writer, it always switched the tab to Table, regardless of the context (whether I’m working with the layout or the content). So each time I want to change the text style I need to click on the Home tab first. Is there a way to stop Writer from switching to Table tab?

I thought that was the point of tabbed mode, isn’t that what Word does?

Why not use the standard mode if it is more convenient?

Yes, Word does that too, but if you switch from table tabs it won’t ever select them unless you do it yourself. Wirter doesn’t respect the selected tab and switches to Table whenever I click inside the table, instead of switching only once when I insert a table.

Why not use the standard mode if it is more convenient?

It is not. I don’t think I will ever get used to that mode. And tabbed seems pretty good besides this issue.

You can always leave the sidebar open.

Or use the keyboard shortcuts: Ctrl+0 for Text Body, Ctrl+1 for Heading 1, etc

Uhh Ctrl+N isn’t what i’m looking for (would there be a shortcut for every option to which Writer’s behaviour prevents an easy access?) Sidebar too, doesn’t it kill the purpose of the tabs? Is there any way to get this issue fixed (bug tracker etc.)?

The tabbed interface has been provided for those transitioning from Word, there are other interfaces for those who prefer them or wish to modify to suit.

I don’t want to guess which shortcuts you want. The Writer Guide has a list of default shortcuts at the back I think. Otherwise, if you click on the Settings icon at the far right of the tabbed toolbar and select Customise then in the dialog that opens click on the Keyboard tab you can scroll down to see what shortcuts are already provided; you can create new keyboard shortcuts too.

You can post bugs, this link takes you to the appropriate section on the Ask/Getting Started page. If you do post a bug please link on this page, e.g. tdf#123456

Yes, you could do a lot with only the Sidebar showing; it’s one of the interface options.

Already in tdf#141136 “Tabbed toolbar mode keeps switching you away from the current tab to the “Home” tab each time you enter (focus) or leave a comment”

Thank you! I will leave a comment on that bug then.