Writer turns double-space into nonbreaking & breaking spaces

I am using LibreOffice for the first time, verion on Windows 10 64-bit. LibreOffice Writer (LOW) It seems to give special treatment to double-spaces that are pasted into a document. It converts the first space into a nonbreaking space, and leaves the second space as normal. Single spaces are also left alone.

The source file is plain text, editted in vim. If I replace all double-spaces by triple-spaces, then no spaces are converted to nonbreaking spaces when pasting into LOW. When I change the triple-spaces into double-spaces again, then I re-observe the above conversion of double-spaces.

I have never before seen such a conversion when pasting from any file (text, code development environments, or word processors) into any other file, so I can only assume that this LOW behaviour is by design.

(1) What is the logic behind this conversion?

(2) Is there any way to disable it?

Are you using just Paste or a Paste Special → Plaintext ?

It happens no matter which I choose. However, I used vim to show the ASCII code under each space, and they are not the same. So the non-breaking space was introduced at the source, from where the text was copied into vim. The source is gmail’s webmail interface, and the text is the email trail that is embedded into a composed message when forwarding a message. Since the mystery is solved, I wonder whether this question is still worth keeping. This comment might help others who use gmail and LO Writer (neither of which is uncommon, though I don’t know how common the combination is)