Writer V 7332 Crashes When Using Slidebar

When using Writer the program will crash at apparently random times, but seems to be related to the use of the slidebar going up and down the document.

Version: (x64) / LibreOffice Community
Build ID: d1d0ea68f081ee2800a922cac8f79445e4603348
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

Documents mostly being used are .doc created with Office 2003 on W7 machine. Now are being modified and saved with LibraOffice on W10. Although, the program has crashed with a .odt create in the W10 environment.

I have already run in the Safe Mode and was not able to duplicate the issue, changed the \User folder to User-old and restarted Writer with no joy.

First steps

Try Step 2 in the Link.

Step 2 is to rename the User Profile and allow LO to recreate it. This did not correct the problem (No Joy) and the other steps in that link did not seem to be related to the issue.


Documents mostly being used are .doc created with Office 2003

It could be a compatibility problem between
ODT and DOC / DOCX .


Recommendation for clean working with LibreOffice when different Office programs are used.
Always create and save your files in LibreOffice and save them in ODF format (ODT, ODS, etc.).
Always keep these files as their source.
If you need other formats for distribution to partners, you can open an ODF file and save and distribute another format with ″ Save as… ″.
This way, you always have working files available in your system environment.


Edit different file formats in LibreOffice

Please report the behavior as a bug in Bugzilla .

See also:

How to Report Bugs in LibreOffice .

Please post the link from the bug here.
format: tdf#nnnnnn (use only the number, not the link)
To do this, edit your initial question. Thank you.


You can upload an anonymized and truncated file where the problem is present here for someone to look at in and test.

Thanks Hrbrgr,

I will try that approach first. If I can clear the issue, great. Else, I will follow up on the remainder and post the bug report here.

Thanks again.

Try step 5 in the link:

Click Tools - Options - View and untick Use Skia for all rendering.

If no more crashes occur you have identified where the issues lie. You can leave Skia off or you could try turning it back on and also ticking the box Force Skia for all rendering (or similar wording)

Cheers, Al

After using the .odt files only, I had some success but after opening multiple files the problem returned. Then it remained. Not sure if it actually went away because it is a randomly occurring fault that seems related to sliding the bar up and down or scrolling with the mouse. Lots of data use then and I have noticed that the program isn’t disk caching when ram is full. I noticed that the amount of ram used was about 800MB, and when in Safe Mode was about 400MB.

I have deselected Skia and opened 5 odt files. Ram usage is now 360MB. Will report back later.

Force Skia software rendering (i.e., use Skia, but without Vulkan acceleration, even when it’s available).

I have reselected Skia and forced (checked the box). I have been running with several files open with a mix .odt, .doc., .docx, and so far no crash when sliding the scroll bar vigorously several times, (this action would cause the ram to fill up and the program to crash). Ram use is about 440MB which seems normal and doesn’t change significantly which scrolling.