Writer won't open documents of any type


I’m running LibreOffice on elementary OS (Linux).

I was working on .docx files last night and all was well. I closed out and turned off my computer. I woke up this morning to find that when I tried to open it again, no dice. I’ve tried opening Writer and opening the document from there, opening it from the folder, document recovery, opening from the terminal, and nothing. I’ve tried killall on the oosplash function, resetting the user profile, uninstalling and reinstalling, downloading the document again (and giving up on hours of work) and saving it in .odt format, but now Writer won’t open anything. Even if I save a completely new .odt file and close out, it won’t open it again.

Please help me. I’ve lost hours of work and it looks like unless I fix this, I can’t even work on anything new because I can’t access it later or send it by email. Can anyone suggest anything and ELI5 (explain like I’m five) how to do it? I’ve exhausted all the options I understand.

I have no advice regarding LO, but maybe to see if you still have an intact file try uploading it to google docs or Zoho and use the online editor there. Or use Abiword or WPS to open the file locally.

Standard advice for LO with Excel files: always store in native LO format (eg odt). Transfer to Excel format, if required for transfer to other person/computer, immediately before transfer.