Writer won't print multiple copies on Linux

LibreOffice Writer will not print multiple copies requested on a Network printer when on Linux.
Have tried on various Linux distros., same problem.
Can only print one at a time.

Update: just tried it on LinuxMint Cinnamon - same problem.

No issues when on Windows 10 though.

Does printing via the Command Line Interface work? As you would expect?

libreoffice --writer --pt {Printername} {file1.odt} {file2.odt} ... {fileN.odt}

If the printer is your default printer, you can use -p instead

libreoffice --writer -p {file1.odt} {file2.odt} ... {fileN.odt}

PS:
What you Question is missing:

  • Printer + Vendor
  • OS + LO + Driver Version (s) combinations used/tried

Keep in mind, the answer(s) will only be as good,
as the information you can provide.

A bit of lateral thinking: if you want to print say 3 copies of page 1, then in the page number box put 1,1,1

The above comments don’t address the problem. I too am looking for an answer to this frustrating issue.
This sort of a workaround is of no interest to the average user who simply wants enter a number and get that many copies from the printer.

You have a problem. Other users, without access to your system, are asking you questions to try and narrow down the issue. You reply “…workaround is of no interest…” implying the other users should have more interest in your problem and more knowledge of your system than you do yourself? Or have I misunderstood? Cheers, Al

BTW.On Mint Linux 19.3, LO 7.0.3.1, I can print as many copies as I like to a networked Brother MFC-J6945DW, or HP 9010

If I press the More Options button and select the “Create separate print jobs for collated output” t still works. I am not entirely sure the point of it on my system, but it might be there to get around a problem such as you have. You could try and see if selecting the option resolves your issue. Or supply the further info that has been asked for.

You might find that you can print multiple copies of a single page but not multi-page documents.

If you send collated printing as separate print jobs it doesn’t matter if the printer deletes each page after printing it. This can be done in the Print Dialog, just press the More Options button and in the small dialog tick the box that says “Create spearate print jobs for collated output”. It will slow down the process of printing multi-page documents so don’t tick it if you don’t need it. Cheers, Al

1 Like