Writer won't save documents

Using libreoffice 5.3.6-1 on manjaro linux (KDE) i got a strange error:
When trying to save files using writer i got some issues:

When trying to save .ODT the file is saved but i get an error message:
Error saving the document Untitled 1:
General Error

When trying to save .docx files, the file is NOT saved an i get the following error:
Error saving the document Untitled 1:
Write Error.
The file could not be written.

This problem occurs only when using writer (impress and calc work O.K)

BTW when opening a .docx from the web it opens like a charm but still cant save any changes.

Already tried removing and reinstalling libreoffice, cleaning ~/.config/libreoffice/4/user/ folder and I obviously have privileges to save the file.

Can anyone please help ???


If anyone ever reaches this I solved it…
I’m not sure but it was solved EXACTLY when I solved an other issue and I don’t believe in such coincidences.

It was somehow related to a discrete graphics card I have on my laptop that had some issues. As soon as I solved them by using the appropriate Kernel parameters (find out more info HERE) Libre seemed to behave properly as well.