Writer's spell check interrupts all the time

As I’m writing (Version: (x64)), I am interrupted several times by the spell checker automatically popping up to notify me of an error. This is really frustrating. Under Options>Language Settings>Writing Aids I have turned off all the options related to checking spelling and grammar while I type, actually there is nothing checked in that third box labeled options.

Your thoughts would be appreciated.

Thank you

Hit Shift + F7. Does it help?