Writing Hebrew in Linux is really slow

Every year I am trying once again, hoping that new versions of LibreOffice or of Ubuntu will allow me to write documents in Hebrew, but it’s always the same: once I have both Hebrew letters and numbers in the same document, LO becomes extremely slow - there is a delay of about 1-2 second between every character, which makes it unusable.

What really perplexes me is that I did not find any bug reports regarding this, even though this has been this way for as long as I remember (since LO supprts Hebrew, I think), and I tried many versions of LibreOffice and many versions of Ubuntu or Ubuntu-mate. I tried various suggestions regarding slowishness of LO in general, but none helped. I also tried turning off all grammar/spelling corrections, to no avail.

Adding numbers to the documents is important - I can write a long document in Hebrew with no problem, but if I only write “שלום 777” from that point onward everything becomes super slow. And I am working on an i9-10885H laptop…

This is really frustrating because it forces me to always have a windows machine with MS office at home, for my childrens’ projects and so on. Did anyone else encounter this? Do any of you manage to write Hebrew+numbers on Linux?

Not experiencing the same mishap here: Fedora 33, KDE Plasma desktop, LO

Just to make sure, have you enabled Complex text layout for Hebrew in Tools>Options, Language Settings>Languages and correctly specified the language for the text fragments?

Note behaviour does not change here if I don’t enable CTL.

Which specific font is used?

Please do not use Add Answer but edit your original question to enhance the details of your question (answers are reserved for solutions to a problem on this Q&A site).

You are using normal .odt files are you? An controlling your output using Styles with No direct formatting. The font you are using contains the Hebrew characters. What version of ibO, User interface, Locale, CTL etc. all the basics.