Wrong input position when typing Asian characters

Version: (x64) / LibreOffice Community
Build ID: a69ca51ded25f3eefd52d7bf9a5fad8c90b87951
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: zh-HK (en_US); UI: zh-TW
Calc: threaded

When typing in Chinese or Japanese (so basically characters), the input position keeps getting stuck at the last position. For example, when I type this string from left to right, without stopping:

一二三一二三 二三
(i.e. 123123 23)

I noticed I missed a 1 (i.e. 一) and I click on the space after the 6th character and type. The character will always appear after the last character and not where it is intended:

一二三一二三 二三
(i.e. 123123 231)

Latin alphabets are not affected at all (i.e. English). I can insert “a” to all the spaces:


and the will still appear after the last character.

Selecting words in the middle and typing (to replace them) will result in the whole chunk of text between the selection and the last typing position to be selected and replaced. So, basically the input position is STUCK at the end of the last Asian character input.

What is causing this? The computer is new and the Libre Office is newly installed.

1 Like

Sorry, I don’t understand this issue. What IME do you use ?
Could you write detail steps of reproduce?
And If you upload screenshot or screencast, they can easy to understand.

I didn’t reproduce it.

What will happen if ‘spelling’ , ‘Automatic Spell Checking’ , ‘AutoCorrectOptions’ and ‘AutoInput’ are turned off?

Version: (x64) / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: ja-JP (ja_JP); UI: ja-JP
Calc: CL