xray install fails

using XrayTool60_en.odt
opened document in Wtiter

installed LibreOffice_7.1.2_Win_x64_sdk.msi - don’t even have a clue how to start it! LOL

My LO progs are the Portable versions from PortableApps.com

Being a legacy programmer, Object Oriented programming remains a mystery - but I’m trying!

I click the “Install Xray” button in the document and nothing happens.

Found the problem. Opened the document by drag and drop to empty Writer document. This treats it as an ‘insert’ rather than an open. It seemed to be in ‘design’ mode. Selecting the install button produced sizing handles.

Just tried opening it from a directory. The install button worked as expected. xray is now installed.

Thanks, you may mark this solved.


PS: The install above was done with a normally installed LO. Below describes getting it installed with the Portable versions (I have more than one machine).

I also discovered that a LO document can be opened via the Open with… dialog on the File Explorer context menu. Simply navigate to the appropriate LO program and select it. In this case it was “LibreOfficeWriterPortable.exe.”
“LibreOfficePortable.exe” will work for any LO document.

By definition, Portable Apps are not in the Windows Registry.

Also note that LO Portables are created in conjunction with LO org - they are not “knockoffs.”

PPS: While properly opening “XrayTool60_en.odt” is necessary, further steps are needed to achieve the actual install on the Portable version. When I figure them out, I will update this post.