Zotero ext. doing weird indentation

When I insert a citation into a document using Zotero, it indents my headings (or rather places a tab before them.) Should I file a bug report, and when, where? LO Bugzilla or Zotero’s (or the extension’s) respective page.

How to reproduce:

  1. Create a new Writer document (and have Zotero and the Zotero LO extension installed).

  2. Add a heading (see below for ‘before’ state, with formatting characters turned on)

  3. Using the Zotero toolbar, insert a citation.

  4. As is visible, the heading is indented using a tab (see below)

This indent will now appear at every heading of every level you insert. As far as I’ve experienced, it doesn’t happen on custom headings (i.e., paragraph templates you’ve created yourself), but only with the factory headings.

This is my LO’s information:

Version: (X86_64) / LibreOffice Community
Build ID: 9f56dff12ba03b9acd7730a5a481eea045e468f3
CPU threads: 4; OS: Windows 10.0 Build 19045; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded

tdf#152158 is fixed starting from 7.5.4.

Is your heading styled Heading n? A screenshot doesn’t show this important information.

If so, there has been a change in a release of the 7.x series which tends to systematically enable numbering/heading text separator management, even when no number is present. And since Zotero is implemented with tons of macros (because it is not a primitive feature in Writer, Word, …), this may cause unintended side effects.

If my guess is correct, you can fix it in Tools>Heading Numbering (or Chapter Numbering in older releases), Position tab where you can request the number to be followed by nothing (do it for all needed levels).

Wording of menus and functionalities differ slightly across platforms. It is then wise to mention OS name, LO version and save format.

@ajlittoz Thanks, but this would then cause problems once I’d actually want to number headings, right? If I understand @mikekaganski correctly,

then this should be fixed. I already updated my LO because of a different issue, and I couldn’t replicate this issue so far, so it appears to have been fixed.

No. Having no number before the heading is rather the “offending” case regarding the separator between number and text. With a numbered heading, just choose your separator as usual: tab, space or newline.