Zotero footnotes: titles lack italics

I’ve been using the zotero plugin for LO for years. Returned to write final papers and now see that footnotes do not have italics for book titles. I’ve updated JDK, reinstalled and updated LO, reinstalled the zotero plugin for LO, updated Zotero, nothing seems to fix it. Zotero’s documentation says that LO governs the formatting of the footnotes. And when I test the formatting in Zotero’s formatting editor, the italics are there and correct.

  • LibreOffice Version:
  • Zotero Standalone: 5.0.28
  • Chicago Manual of Style 17th Edition (note)

I’ve tried to modify the footnote style, but I don’t see how I can edit the presence of italics in a portion of the footnote using that dialog. I can change the font size and spacing etc of the entire footnote, but not the appearance of an individual section of the footnote… Anyone run into this? As a workaround, it is possible to manually change each footnote to have italics where required but this is clearly a regression from prior functionality.

Also see LibreOffice plugin: No italics in CMS footnotes - Zotero Forums

Yeah that’s me.

That’s called cross posting and people tend to hate it a lot because it means more work - you get a discussion dealing with the same points on two places instead of one, and one of the topics may still get new posts when the problem has been solved in the other. No hard feelings to you, but please remember to post links to other places where you ask the same question.

Thanks for the lecture. Given that this may be a LibreOffice issue, or it may be a Zotero issue, I decided to post once in both places. I did my due diligence and did a great deal of troubleshooting before posting. I have also provided platform information. This question is also different from the other. And until one or the other has a solution, well, it doesn’t make much sense to provide a link. But I guess every platform needs someone to police it.

I beg your pardon? I pointed this out in a friendly way and you manage to mistake it for flaming?

You may have to file a bug report at the LibreOffice bug tracker: https://bugs.documentfoundation.org/

Maybe the developers changed the import filter for the zotero content so that the codes for italics are no longer taken into account.

This was a Zotero bug. Installing 5.0.28-beta.2+824114907 and resetting the style in the LO Zotero plugin document preferences fixed the issue.