English
Ask Your Question
1

Does LibreOffice run on Windows 8.1, Windows Server 2008 R2 and Windows Server 2012?

asked 2014-01-06 22:17:53 +0200

Gerry gravatar image

updated 2014-01-06 23:29:00 +0200

oweng gravatar image

I would like to know whether LibreOffice 4.1.x / 4.2 also installs and nicely runs on:

Windows Server 2008 R2

Windows Server 2012

Windows 8.1

I am referring to bug 71690 ( https://bugs.freedesktop.org/show_bug.cgi?id=71690 ) asking for additions to the LibreOffice "system requirements" webpage where these OS are actually missing (as well as FreeBSD). I assume that no one has made these additions there yet, because no one has confirmed that LO nicely runs on these systems.

Can you confirm that these three OS are nicely supported by LibreOffice?

Thanks!

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2014-01-11 12:02:10 +0200

Gerry gravatar image

Does anyone successfully use LibreOffice on Windows Server 2012? And Windows 8.1?

With regards to Windows Server 2008 R2, there is this entry and it seems to work fine.

edit flag offensive delete link more
0

answered 2014-01-07 00:58:43 +0200

oweng gravatar image

I will only attempt to address the Windows 8 part of this question.

Can you confirm that these three OS are nicely supported by LibreOffice?

This statement can mean a lot of things, as Dennis Hamilton pointed out, with respect to Windows 8, on the Users mailing list in December 2012. Quote: "anything that is compatible with Windows 7 should work." The thread Can I run LibreOffice on windows 8 64? (in which you have provided an answer) is related. I also indicate in an answer here that given the number of threads dealing with Windows 8 related issues that "compatibility" is difficult to determine. Microsoft have not done themselves any favours in this respect.

edit flag offensive delete link more

Comments

Thanks, oweng. In the LibreOffice system requirements, the compatibility with Windows 8 is already indicated ( http://www.libreoffice.org/download/system-requirements/ ). Is compatibility of LO with Win 8.1 similar to Win 8?

Gerry ( 2014-01-07 03:01:23 +0200 )edit

Presumably. There does not appear to much in the way of win8-specific changes highlighted in the git code repository, although these may be under some other tag. I can't find anything that would indicate LO specifically looks for the Win8 code of _WIN32_WINNT_WIN8 (0x0602). The only platform-specific Windows code appears to be for XP and Vista.

oweng ( 2014-01-07 13:40:17 +0200 )edit
Login/Signup to Answer

Question Tools

Follow
2 followers

Stats

Asked: 2014-01-06 22:17:53 +0200

Seen: 2,524 times

Last updated: Jan 11