English
Ask Your Question
4

Full A4 background image in Writer

asked 2012-08-09 17:19:21 +0200

Hello, I have received some images from a designer so I am able to make up my stationary. I have made the image the full size of A4 but when I set it as the background image the margins put white space over it. Is there anyway to truly make it background so that I can see my full design ? Thank you.

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
7

answered 2012-08-10 00:21:31 +0200

Don't add it as a background for the page, as that is limited to the printable area/the area defined by the page-margin.

Instead

  • insert the graphic into the document,
  • choose Anchor|To Page from the contextmenu
  • choose Wrap|In Background from the contextmenu

If the graphic should appear on all pages, insert a header or footer and anchor the graphic to a paragraph or character in the header or footer, then choose Picture from the contextmenu. On the Type tab, in the Position section choose left/top to Entire Page. As with the previous method, set wrap mode to "in background".

edit flag offensive delete link more

Comments

This appears to work well though I am struggling to see how you anchor the image to a character in the footer. I have added a footer with our company address in it, opened the picture contextmenu and select Anchor->to character but what does one do next ?

INNOVOT ( 2012-08-10 10:58:28 +0200 )edit

Every time I click on Anchor->To Character the Anchor graphic appears on the first character of the main text. How do you select a character from within the footer ?

INNOVOT ( 2012-08-10 11:44:18 +0200 )edit
1

@INNOVOT: did you put the cursor into the footer before inserting the image? AFAIK the anchoring position is determined by the cursor postion on insert.

tohuwawohu ( 2012-08-10 12:08:19 +0200 )edit
2

select graphic, <ctrl>+x, cursor into the footer, <ctrl>+v (i.e. cut and paste the graphic), alternatively put the cursor into the footer before inserting the image. Dragging the gray anchor symbol to/from header/footer doesn't work anymore since the change of header/footer display.

cloph ( 2012-08-10 12:34:58 +0200 )edit
1

Its Friday so if you could see me you would watch me dancing! Worked perfectly.

INNOVOT ( 2012-08-10 12:44:21 +0200 )edit
0

answered 2013-04-10 21:46:05 +0200

Thank you for showing how to make full page image background in Writer. Now the image is there, sent to the background, already-entered text is there above the image, but I can not edit the text any more. When I shrink the image so that text area gets larger than the image, clicking outside the image lets the text be edited. But how can I edit the page text when the image (anchored to page, wrapped to background) covers the whole page?

edit flag offensive delete link more

Comments

@Editor, you are experiencing a regression as indicated in this bug: https://bugs.freedesktop.org/show_bug.cgi?id=66215 It appears to have become a problem some time in the v3.6 series.

oweng ( 2013-08-03 10:24:48 +0200 )edit

fdo#66215

Status: RESOLVED FIXED

(target: 4.0.6 / 4.1.2 / 4.2.0)

manj_k ( 2014-01-09 00:16:04 +0200 )edit

I'm facing the very same issue with LibreOffice 4.2.

Putting a whole page-sized image that way on the page is kind of easy and straight forward, but try as I might, I'm simply failing to spot how to enter new/change existing text.

Sil68 ( 2014-02-12 16:14:15 +0200 )edit

@Sil68 – Click into the (gray) application background (to the left or right of the document), so that the green handles (of the image) disappear. Then click into the document for editing. That works for me with LibreOffice 4.2.0.4 (on Windows 7).

manj_k ( 2014-02-12 17:15:27 +0200 )edit
Login/Signup to Answer

Stats

Asked: 2012-08-09 17:19:21 +0200

Seen: 11,192 times

Last updated: Apr 10 '13