Frage stellen
1

Meta Files werden nach Neustart zu Bitmaps

gefragt 2019-06-07 09:19:13 +0200

ordnerordner Gravatar-Bild

updated 2019-06-07 12:47:59 +0200

Hallo,

ich habe ein Problem mit Meta Files und würde mich über etwas Hilfe freuen. Ich habe in LibreOffice Draw (6.1.6 -- geupdatet!) und Windows 10 einen Netzwerkplan erstellt. Als Symbole habe ich diese Extension benutzt: https://extensions.libreoffice.org/ex...

Die Symbole aus der Extension konvertiere ich immer zu Meta Files, damit sie sich gut skalieren lassen. Insgesamt sind es etwa 30 Symbole auf 4 Folien, die mit Klebepunkten versehen und über viele Verbinder miteinander verbunden sind. Wenn ich mein Projekt speichere, Draw schließe und dann wieder öffne, wurden einige Meta Files durch unscharfe Bitmaps ersetzt, während andere unverändert bleiben.

Das ist jetzt schon mehrfach passiert, und jedes Mal habe ich die Symbole repariert. Also Symbol gelöscht, dann eine Kopie von einem passenden Meta File gemacht, Klebepunkte angepasst, usw.

Ist das ein bekanntes Problem? Gibt es vielleicht eine Höchstzahl an Meta Files, mit denen Draw klarkommt? Danke für jede Hilfe!

Screenshots (der rechte Teil kommt aus einem exportierten PDF, das direkt nach der Bearbeitung des Dokuments entstanden ist):

Bildbeschreibung

Gruß

EDIT:

Auf Lupps Kommentar hin, hier ein paar Ergänzungen: Ich hänge zwei Dateien an und hoffe dass das so funktioniert:

dummy_einzeln_erzeugt_Original.odg und

dummy_mehrere_Speicherungen.odg

Beide enthalten folgende Shapes, allesamt einzeln eingefügt: 1.) 3 mal ein von mir benutzerdefiniertes Meta File auf Basis der VRT Networking Extension. 2.) 3 mal ein generisches Computer-Shape aus LibO, eingefügt und dann zu Meta File umgewandelt. 3.) 3 mal ein Shape aus der VRT Networking Extension, bis auf die Umwandlung zum Meta File unverändert.

Mir ist beim testen aufgefallen: Wenn ich ein Shape in ein Meta File umwandle und dieses dann kopiere, das Dokument abspeichere und neu öffne, sind die Kopien bereits wieder Bitmaps. Bei den einzeln erzeugten Shapes, also bei den Shapes die als Bitmap erzeugt und dann erst zu Meta Files umgewandelt wurden, tritt der Effekt erst nach zwei Speicherungs-Neuöffnungs-Zyklen auf (siehe Dokumente im Anhang).

@Lupp: Ich hoffe, das ist was du meintest. Wenn noch Angaben gebraucht werden, bitte Bescheidgeben!


Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Ohne konkretes Beispiel als funktionsfähige ODF-Datei keine Chance, fürchte ich. Mach ein Beispiel mit einer Graphik, deren Metafile bei dir verbitmapt wird, dupliziere die Graphik vor der Konvertierung, und konvertiere dann nur das eine Exemplar. Speichere und lade neu, um zu den Fehler zu verifizieren.
Editiere deine Frage und hänge das Beispiel als .odg (oder .odp ?) an. Dann kann hier jemand mit der Aufklärung des Problems starten.
Auch_1: Manche sehr seltsamen Fehler können von einem beschädigten Benutzerprofil kommen.
Auch_2: Wenn der Effekt bei ganz bestimmten Symbolen reproduzierbar auftritt, wäre meine erste Vermutung, dass die Extension Elemente mit Bug enthält. (Shapes können ziemlich komplex sein.)
Auch_3: Hast du nach einem entsprechenden BugReport für LibO Draw gesucht? Hast du mit einer der jüngsten Versionen (6.2.4.2; 6.3.0.0.beta1) getestet? Ist deine Extension V1.2.0?

Lupp Gravatar-BildLupp ( 2019-06-07 11:08:26 +0200 )Bearbeiten

Hallo Lupp, danke für deine Antwort. Ich habe meine Frage etwas angepasst.

Bzgl. Auch_2: Das Problem tritt auch bei den in LibO integrierten Shapes auf.

Bzgl. Auch_3: Die Extension hat Version 1.2.0. Einen Bug-Report konnte ich nicht finden. Beta-Software darf ich leider nicht auf diesem PC installieren.

ordnerordner Gravatar-Bildordnerordner ( 2019-06-07 12:42:00 +0200 )Bearbeiten

Ich konnte die beschriebenen Phänomene nicht reproduzieren. Ich habe mit
V 6.2.3.2, V 6.3.0.0.beta1 (jeweils 64bit unter Win 10) und mit V 6.1.2 (PortableApp, 32bit, auch unter Win 10) probiert. Metafile bleibt Metafile.
Vielleicht doch einmal nach Umbenennung des vorliegendenj Benutzerprofils versuchen ob das Gespenst verschwindet? Weißt du, wie man das macht?

Lupp Gravatar-BildLupp ( 2019-06-07 15:20:23 +0200 )Bearbeiten

Hallo Lupp, Das mit dem Benutzerprofil werde ich probieren, aber erst am Dienstag. Ich melde dann hier zurück, ob das funktioniert hat. Vielen Dank erstmal für deine Mühe!

ordnerordner Gravatar-Bildordnerordner ( 2019-06-07 15:26:31 +0200 )Bearbeiten

1 Antwort

2

geantwortet 2019-06-07 20:36:16 +0200

Regina Gravatar-Bild

In der default-Einstellung speichert LibreOffice zusätzlich zu seinem eigenen Vektorformat .svm auch noch ein Ersatz-Bild im .png Format. Damit können andere Anwendungen, die mit .svm nichts anfangen können, trotzdem ein Bild zeigen. Es gibt inzwischen eine Experteneinstellung, mit der man unterbinden kann, dass solche Ersatzbilder erzeugt werden.

Extras > Optionen > Erweitert. Klicke auf Experteneingstellungen. Suche nach AddReplacementImages. Mit einem Doppelklick auf die Ergebniszeile wechselst du zwischen true und false. Probiere mal, ob dir die Einstellung 'false' weiterhilft.

Eigentlich sollte, wenn zwei Formate gespeichert werden, immer das bessere, hier also .svm benutzt werden. Wenn das nicht der Fall ist, könnte in dieser Version ein Fehler vorliegen. Dann würde ich mal probieren, ob das Problem in einer aktuellen Developer-Version auch besteht.

Bearbeiten Melden löschen Link mehr

Kommentare

Sehr interessant.
(Wie oben gesagt habe ich aber mit mehreren Versionen ohne Erfolg versucht, den Fehler zu provozieren.)

Lupp Gravatar-BildLupp ( 2019-06-07 22:23:31 +0200 )Bearbeiten

Hallo Regina, vielen Dank für deine Antwort. Ich habe deinen Vorschlag ausprobiert und es scheint zu funktionieren. Sobald ich AddReplacementImages wieder auf 'true' setze und dann speichere, tritt das Problem wieder auf (LibO 6.1.6.3). Sollte ich das irgendwo melden? Ich danke euch beiden für die Hilfe!

Ich finde es interessant, dass der Fehler nur bei manchen der Shapes auftritt, nicht bei allen Instanzen derselben Vorlage.

ordnerordner Gravatar-Bildordnerordner ( 2019-06-11 08:49:12 +0200 )Bearbeiten

@Regina: Die Anwendung des Replacement im beschriebenen Fall ist doch wohl als Bug zu sehen. Schließlich hat der OQ ja nicht über die Darstellung in einer "anderen Anwendung" geklagt. Kennst du da einen Bugreport?

Lupp Gravatar-BildLupp ( 2019-06-11 12:41:15 +0200 )Bearbeiten

AddReplacementImages auf false zu setzen ist nur ein Workaround um im konkreten Fall überhaupt produktiv weiterarbeiten zu können. Es ist natürlich ein Bug, wenn nicht der Metafile sondern das Bitmap geladen wird. Ja, ein Bugreport sollte geschrieben werden, falls das Problem auch in der 6.2-Version bei einer neuen Datei auftritt. Vielleicht kann jemand anderes den Fehler reproduzieren. Die 6.1-Versionsreihe ist "end of life", ein Report gegen die 6.1-Version bringt nichts.

Regina Gravatar-BildRegina ( 2019-06-11 14:10:50 +0200 )Bearbeiten
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2019-06-07 09:19:13 +0200

Angesehen: 28 Mal

Aktualisiert: Jun 07