Ask Your Question
0

Problems with Opening and Saving a Document over a Network [closed]

asked 2012-03-20 07:42:10 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

We are using Ubuntu 11.10 in the office. Opening and saving a document to the home drive works well.

If you need to open a document located in a folder on a network server, you firstly find that there is no obvious support in LibreOffice for browsing a network. To get around this, I created a bookmark using the "Places" application that comes with Ubuntu. This then appears in the LibreOffice file opening dialogue. Using the bookmark, it is possible to browse to a document but when the document is selected and the "Open" button is clicked, the browse window closes to return back to LibreOffice but the page in LibreOffice remains blank.

This happens on two machines running Ubuntu 11.10. We used to be able to open documents on a network share with 11.04 (I think!).

I downloaded directly from the LibreOffice site, the latest stable version of LibreOffice, (3.5 - The one provided by Ubuntu 11.10 is LibreOffice 3.4.4 OOO340m1 (Build:402)). I installed that. This did not solve the problem.

I then loaded the latest Mint distribution onto another computer. It, too, has the same problem. At that point I thought I should report this in the hope of being helpful.

I have also performed the following experimentation to try to identify the nature of this problem and to see if I was possibly doing something wrong or omitting something.

Using "Places" I browsed to a document on the network, right-clicked on it and selected "Open with LibreOffice Writer" from the context box. The document opens perfectly. I then altered the document slightly and saved it. It seemed to save perfectly. I then opened the document, using "Places" again. The changes had been saved. I then altered the document again and tried to perform a "Save As", saving the document with a slightly different name. This gave rise to the error, "Error saving document [name of document]: General Error. General input/output error."

Using "Places" I navigated to a document on a network share, opened it, altered it, saved it, and then closed the document. I then selected "File, Open" in LibreOffice and noted that the document was listed in the "Recent documents". I clicked on that item in the list and the document opened. When hovering over the item in the "Recent documents" list, I noted that the path was ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-19 22:28:51.273588

Comments

I guess that most of these issues are related to the way your network server is set up in Ubuntu - and that this is not related to LibreOffice at all.

If you use gedit (text editor not related to LibreOffice) do you have the same issues with opening/saving files?

ehansen gravatar imageehansen ( 2012-03-20 10:49:26 +0200 )edit

This is definitely a network config issue. All my LO documents are accessed across a network here (Ubuntu 10.04 / LO 3.5.1.2) without issue. NFS share on server. Local mount point on client for NFS export. Symlink under /home/<user> to local mount for convenience.

oweng gravatar imageoweng ( 2012-03-28 04:23:13 +0200 )edit

5 Answers

Sort by » oldest newest most voted
1

answered 2012-04-18 19:27:36 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I had the same issue. GVFS and LO don't seem to play along. I can mount with NFS or CIFS by hand and I do not have these issues. BTW, gedit was able to save just fine using GVFS. I am only having this issue with LO.

Anyway, I resolved it by just mounting my share with CIFS through my fstab instead of dealing with gvfs.

edit flag offensive delete link more
1

answered 2013-01-10 19:19:05 +0200

Johnius gravatar image

Yoonix -

Could you provide the fstab edits you made? I spent hours trying to get the syntax correct with my Kubuntu 12.04 systems trying to mount a Windows XP NTFS share. I'll be upgrading the machines as soon as 13.04 comes out, but in case LO hasn't fixed the issue by then, I'd like to be able to fix it myself.

Thanks, Johnius

edit flag offensive delete link more

Comments

According to this Ubuntu Forums thread you should use: //netbiosname/sharename /media/sharename cifs credentials=/root/.smbcredentials,iocharset=utf8,nobrl,file_mode=0777,dir_mode=0777 0 0 but also note this AskLO thread about patches to the LO v4.0 series.

oweng gravatar imageoweng ( 2013-06-12 02:35:29 +0200 )edit
0

answered 2012-04-25 02:04:07 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Equipment: Ubuntu 11.04 recently updated from 10.something. Windows network connection in a workgroup called WORKGROUP. A network server with lots of files. A Windows XP computer in a different workgroup in the same network.

I can see, upload and download files between my Ubuntu computer and all the other places. Before the Ubuntu update, when the office program was OpenOffice, I could open and save files from OpenOffice to all the other places. After the upgrade, with OpenOffice replaced by LibreOffice (and OpenOffice no longer available), I cannot open or save files from within LibreOffice because LibreOffice demands a username and a password. Entering the ones applying to my network drive or those applying to the Ubuntu computer doesn't work. If I download a file, e.g. to the Ubuntu desktop, then I can open it with LibreOffice. What do I do to make LibreOffice work?

Ken1

edit flag offensive delete link more
0

answered 2012-04-26 00:44:33 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Further to my message yesterday: a) Yes, some other programs, such as gedit, do have access to the network drives without entering a username and password. b)There was no change to the network, only to the Ubuntu computer with LibreOffice instead of OpenOffice, so the problem has to be with LibreOffice, not with the network. If I knew what username and password to enter, perhaps it would work, but neither those for my network access nor for authentication within the Ubuntu computer work. I note from the internet that others have run into the same problem. There must be a solution!

Ken1

edit flag offensive delete link more
0

answered 2012-10-10 07:09:12 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Yeah I had the same issue, when I try to "save as" to network, first error appear: "Error saving document [name of document]: General Error. General input/output error." but somebody tell me (in other forum) to install libgnomevfs2-extra and it's worked.

But after that appears another one, it tells: "Error saving document [name of document]: Nonexistent object. Path to the file doesn't exist."

Please help me. Sorry for my poor English. Thanks.

FYI: Operating System : Ubuntu 12.04 Libreoffcie Version : 3.6.2

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-03-20 07:42:10 +0200

Seen: 16,377 times

Last updated: Jan 10 '13