Problems with Opening and Saving a Document over a Network

We are using Ubuntu 11.10 in the office. Opening and saving a document to the home drive works well.

If you need to open a document located in a folder on a network server, you firstly find that there is no obvious support in LibreOffice for browsing a network. To get around this, I created a bookmark using the “Places” application that comes with Ubuntu. This then appears in the LibreOffice file opening dialogue. Using the bookmark, it is possible to browse to a document but when the document is selected and the “Open” button is clicked, the browse window closes to return back to LibreOffice but the page in LibreOffice remains blank.

This happens on two machines running Ubuntu 11.10. We used to be able to open documents on a network share with 11.04 (I think!).

I downloaded directly from the LibreOffice site, the latest stable version of LibreOffice, (3.5 - The one provided by Ubuntu 11.10 is LibreOffice 3.4.4
OOO340m1 (Build:402)). I installed that. This did not solve the problem.

I then loaded the latest Mint distribution onto another computer. It, too, has the same problem. At that point I thought I should report this in the hope of being helpful.

I have also performed the following experimentation to try to identify the nature of this problem and to see if I was possibly doing something wrong or omitting something.

Using “Places” I browsed to a document on the network, right-clicked on it and selected “Open with LibreOffice Writer” from the context box. The document opens perfectly. I then altered the document slightly and saved it. It seemed to save perfectly. I then opened the document, using “Places” again. The changes had been saved. I then altered the document again and tried to perform a “Save As”, saving the document with a slightly different name. This gave rise to the error, “Error saving document [name of document]: General Error. General input/output error.”

Using “Places” I navigated to a document on a network share, opened it, altered it, saved it, and then closed the document. I then selected “File, Open” in LibreOffice and noted that the document was listed in the “Recent documents”. I clicked on that item in the list and the document opened. When hovering over the item in the “Recent documents” list, I noted that the path was shown as /home/[name of user]/.gvfs/[sharename on servername]/[folder name]/[document name].

I have the feeling that there might be some sort of disconnect between Open Office working with the Gnome virtual file system and the link provided by the bookmark. I note that in the package there is an LibreOffice Gnome Integration Module but wonder if it is working properly with the latest distribution of Ubuntu.

As a final experiment, I selected “Tools/Options” in LibreOffice Writer. Then selected “LibreOffice/Paths/My Documents”. I clicked on the Edit Button and this took me to a browse. By clicking on the “Enter as a Name” Icon in the top left hand corner of the browse dialog, I was presented with an input field. As I typed in the path, it helpfully filled in the remainder. Once the path was properly defined, I selected “OK”. The path that was originally in the My Documents path specification remained unchanged. If I selected the path using the browse without typing in the path, the My Documents path specification goes blank. When I type in a path without the .gvfs, that is on my computer’s diskdrive, the specification works and is displayed correctly in the My Documents path.

I promote the use of Open Source Software to businesses. Being able to create, save, open, alter and save edited documents over a network is quite an important feature. As a suggestion, it would be good if, in the OpenOffice browse, there was a button to look at the network just as there is in “Places”. It would also be good if it were possible to alter document and folder names as one can do in Windows and Microsoft Office rather than having to go back to “Places” for this functionality.

I hope this is helpful to someone.

I guess that most of these issues are related to the way your network server is set up in Ubuntu - and that this is not related to LibreOffice at all.

If you use gedit (text editor not related to LibreOffice) do you have the same issues with opening/saving files?

This is definitely a network config issue. All my LO documents are accessed across a network here (Ubuntu 10.04 / LO without issue. NFS share on server. Local mount point on client for NFS export. Symlink under /home/ to local mount for convenience.

I had the same issue. GVFS and LO don’t seem to play along. I can mount with NFS or CIFS by hand and I do not have these issues. BTW, gedit was able to save just fine using GVFS. I am only having this issue with LO.

Anyway, I resolved it by just mounting my share with CIFS through my fstab instead of dealing with gvfs.

Yoonix -

Could you provide the fstab edits you made? I spent hours trying to get the syntax correct with my Kubuntu 12.04 systems trying to mount a Windows XP NTFS share. I’ll be upgrading the machines as soon as 13.04 comes out, but in case LO hasn’t fixed the issue by then, I’d like to be able to fix it myself.


According to this Ubuntu Forums thread you should use: //netbiosname/sharename /media/sharename cifs credentials=/root/.smbcredentials,iocharset=utf8,nobrl,file_mode=0777,dir_mode=0777 0 0 but also note this AskLO thread about patches to the LO v4.0 series.

Equipment: Ubuntu 11.04 recently updated from 10.something. Windows network connection in a workgroup called WORKGROUP. A network server with lots of files. A Windows XP computer in a different workgroup in the same network.

I can see, upload and download files between my Ubuntu computer and all the other places. Before the Ubuntu update, when the office program was OpenOffice, I could open and save files from OpenOffice to all the other places. After the upgrade, with OpenOffice replaced by LibreOffice (and OpenOffice no longer available), I cannot open or save files from within LibreOffice because LibreOffice demands a username and a password. Entering the ones applying to my network drive or those applying to the Ubuntu computer doesn’t work. If I download a file, e.g. to the Ubuntu desktop, then I can open it with LibreOffice. What do I do to make LibreOffice work?


Further to my message yesterday: a) Yes, some other programs, such as gedit, do have access to the network drives without entering a username and password. b)There was no change to the network, only to the Ubuntu computer with LibreOffice instead of OpenOffice, so the problem has to be with LibreOffice, not with the network. If I knew what username and password to enter, perhaps it would work, but neither those for my network access nor for authentication within the Ubuntu computer work. I note from the internet that others have run into the same problem. There must be a solution!


Yeah I had the same issue, when I try to “save as” to network, first error appear: “Error saving document [name of document]: General Error. General input/output error.”
but somebody tell me (in other forum) to install libgnomevfs2-extra and it’s worked.

But after that appears another one, it tells:
“Error saving document [name of document]: Nonexistent object. Path to the file doesn’t exist.”

Please help me.
Sorry for my poor English.

Operating System : Ubuntu 12.04
Libreoffcie Version : 3.6.2