We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

How do I begin page numbers on page 2 in Writer [closed]

asked 2013-03-04 00:50:07 +0200

Clueless gravatar image

updated 2020-09-12 15:12:15 +0200

Alex Kemp gravatar image

This ought to be relatively straightforward, but it is not. I am having a great deal of trouble with simply starting page numbers on page 2 of a writer document with "2". I want to insert page numbers in a footer. I want the numbering to start on page 2, not page 1. I can not find a solution to this. Kindly help. Thanks in advance.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2021-05-10 16:00:30.752053

5 Answers

Sort by » oldest newest most voted

answered 2013-03-04 07:25:56 +0200

razon_22 gravatar image

updated 2015-01-15 04:28:00 +0200

You can do this with Page Styles. These steps will apply two page styles to a document – one for the first page with no footer, the second for the rest of the document with a footer and page number.

  1. Create a new document.
  2. Type or paste text on page 1 and 2.
  3. Click somewhere in page 1.
  4. Click on the Styles and Formatting icon on the Formatting toolbar. The Styles and Formatting window will open. Click on the Page Styles button at the top of the window. Now double-click the First Page style. This applies the First Page style to your first page.
  5. Click somewhere on page 2.
  6. Insert a footer by choosing Insert > Footer > Default Style from the main menu.
  7. Choose Insert > Fields > Page Number

You now have page numbers starting on page 2 with “2”. If you need further customization for your pages, right-click on the Page Style name and choose Modify.

UPDATE: I have found the way to start page numbering at an arbitrary number, like many are asking for. See the attached example file for instructions, and well, an example. :) PageNumExample.odt

edit flag offensive delete link more


Hi @Clueless -- Did @rmfaile's Answer work for you? If so, please mark it as correct. If not, please let us know so we can endeavor to help you further :-)

qubit gravatar imagequbit ( 2013-03-12 02:41:13 +0200 )edit

You, sir, are a genius. Thank you so much for the answer. If I knew who you were I would buy you a beer. Then take you out and get you laid. Then buy you chicken and waffles the next morning. Believe it.

Clueless gravatar imageClueless ( 2013-03-14 19:09:32 +0200 )edit

@Clueless - Oh, too funny! rofl!!! Glad it helped.

razon_22 gravatar imagerazon_22 ( 2013-03-14 22:00:22 +0200 )edit

@razon_22 Am I the only one who thinks that this is a really pain in the a... ? I followed the steps from above and now my first page has 'First Page' style. Great (i should get myself a prize for that); Now I would also like the 2,3,4,5 pages to have "First page" style, and just the 6-th one to be "Default". Is this even posssible ???? I did the exact same thing but just page 1 hase "First page" style ?!?! Whhhyyyy???PLEASE HELP ME

eer4 gravatar imageeer4 ( 2014-06-15 07:26:01 +0200 )edit

@eer4 Sorry it's a pain for you. When you apply a page style to a page, LibreOffice automatically applies a page style to the next page. To change the style that gets applied to the next page, right-click on the First Page style (in Styles and Formatting), click the Organizer tab, then select the Next Style dropdown. To get 5 first pages, with the 6th default: apply First Page to page 1, click somewhere in page 1, click on the New Style from Selection dropdown at the top of Styles and Formatting. Select New Style from Selection and give it a name like BeforeFirstPage. Right click on BeforeFirstPage, choose Modify, click on the Organizer tab. Choose the dropdown next to Next Style and choose BeforeFirstPage. Apply this BeforeFirstPage style to your first 4 pages. Now click on page 5 of your document and apply the FirstPage style. Page 6 ...(more)

razon_22 gravatar imagerazon_22 ( 2014-07-30 20:40:30 +0200 )edit

I tried this and failed as well!

So I would like to number my pages but I would like to start on page 2 but have it be numbered as page 1 for my thesis. How do I do this?

bdub gravatar imagebdub ( 2014-09-11 04:02:09 +0200 )edit

Can't do it. It's a flaw they refuse to correct. I complained about this several years ago after trying to format a manuscript for a novel.

BKA gravatar imageBKA ( 2014-12-07 02:22:23 +0200 )edit

@bdub@BKA, It is possible, the fuctionality is already there, just not quite so obvious. See the update to my answer above. The confusion is because the question @Clueless asked is different from the one you asked. The initial instruction I gave to him is correct for his question. He just wanted to start page numbers on page 2. However, your question is about starting page numbers on a page and to be able to choose the page number that gets printed in the footer. The update addresses this point

razon_22 gravatar imagerazon_22 ( 2014-12-28 16:14:40 +0200 )edit

After further testing, the instructions I gave to @eer4 above do not work. The instructions are sound (read: should work), but do not, most likely due to bugs in how page styles are applied/updated. I could not get more than one page style to apply correctly to a document. The only workaround I see is to use multiple documents, one for each page style, print, and piece the documents together. I know that's not a real solution. @BKA is correct.

razon_22 gravatar imagerazon_22 ( 2014-12-29 03:03:27 +0200 )edit

@razon_22: I know I am probably headed for a forehead slap, but I cannot get my header "page x of [total pages]" to start with "page 2 of [total pages]." The first header to appear in my document is on page 2, but it reads "page 1 of [total pages]." Any advice?

robc88 gravatar imagerobc88 ( 2016-03-20 01:49:26 +0200 )edit

answered 2015-01-05 06:58:28 +0200

InkingHubris gravatar image

I've seen in the comments here about starting page numbering on page 2 but have it show as 1. Everyone says it can't be done, but it can and its very easy. Open your multi page document and ensure your cursor is on the first page (title page for example) then choose Format>>Title Page. In the pop up that appears check the box next to "Reset page numbering after title pages" and select the page number you wish the count to start on ("1" in our single skipped page example). If you have more pages between the first page and the start of your numbered work (table of contents, etc) check the radio button next to "Insert new title pages" and tell the document how many pages to skip numbering (treat as unnumbered title pages).

Save your document.

edit flag offensive delete link more


Nice post. Thanks. I learnt a new method from you.

Googly Googly gravatar imageGoogly Googly ( 2015-01-13 17:58:49 +0200 )edit

I assume from what I've read thus far, that there is no way to set the first page to no number, a set of roman numerals for a preface (approximately I -X) and then have the main body begin numbering at 1 beyond that point. If anyone can offer advice as to whether this is possible, and if so, how, that would be wonderful! I've tried but with no luck. Many thanks.

Eoghancb gravatar imageEoghancb ( 2015-08-04 23:06:10 +0200 )edit

answered 2015-01-13 17:57:31 +0200

Googly Googly gravatar image

There yet another way to do. Click at the start of the first para of the page of which you want to change the page number with desired number. Choose Insert>Manual Break>Page break, Select the style for the page, check the box for Change page number, type the desired page number in the box below it. Click Ok. If you were already in a new pagem you will get one blank page. Go to the last character of page above the blank page and delete till the blank page gets deleted. Done. You must know the page style which will be of the page with desired number.

edit flag offensive delete link more


Nice. Since I actually wanted that first blank page, I used only your first instruction. Works like a charm. It updates the summary too ;)

Timoteo gravatar imageTimoteo ( 2016-01-01 17:17:06 +0200 )edit

This is the easiest way but it only applies if using title pages. There are other occasions that this method may not apply, like having several sections each with its own page count. For something like that the page style method is the way.

ventolinmono gravatar imageventolinmono ( 2017-10-04 21:48:32 +0200 )edit

answered 2018-03-08 13:07:17 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Thank you Inking, your method worked fine for me. However, if I add also the page count (to obtain Page 1 of 156 for example), I have a problem: the page count tells me 6 though there are 5 pages including the index (which is page 0). is there a way to correct the page count as well?

edit flag offensive delete link more

answered 2018-05-20 15:27:47 +0200

kkkkk gravatar image

updated 2018-05-20 21:17:12 +0200

Eoghancb wrote: "I assume from what I've read thus far, that there is no way to set the first page to no number, a set of roman numerals for a preface (approximately I -X) and then have the main body begin numbering at 1 beyond that point. If anyone can offer advice as to whether this is possible, and if so, how, that would be wonderful! I've tried but with no luck. Many thanks."

@ Eoghancb, i know it's late, but also for anyone searching for a way to set it up, this is how you do it:

lets say you have a document with 15 pages, first you must add the page numbers:

  1. create the Header OR Footer, depending where you want the page numbers to be. in this example we will place them in the Footer: click Insert-> Header&Footer -> Footer -> Default Style

  2. add page numbers: click with the mouse in the empty space in the Footer of the first page, and click Insert -> Field -> Page Number

  3. in the Footer, click with your mouse on the space just before the shown page number, and adjust its location to the middle, or to the right of page, just like you would do with text, by clicking the "Center Horizontally" or "Align Right" buttons you can select above the text on top of the page where are various icons.

next you want to set the first page as "no number":

  1. make sure you click somewhere in the first page so that the cursor is on the first page, and then click Format -> Title Page = a window named "Title Page" opens.

  2. there you have a few options - on the "Place title pages at" section you make a mark on "Page", and set the number as 1.

  3. make a mark on the "Reset page numbering after title pages", and leave page number as 1.

  4. make a mark on the "Set page number for first title page", and set the page number as 0.

  5. click OK.

then you want to change the numbers from arabic to roman symbols:

  1. in the Footer, click with your mouse on the space just before the shown number, and then "double click" that same space = a window named "Edit Fields" opens.

  2. in the Format section choose the appropriate roman style.

(optional: in the Offset section there is a 0 = this means that the first page after the title page will begin with a 1. if the offset is 1, the first page after the title page will begin with a 2. if the offset is -1, the first page after the title page will begin with a 0, you get the drift.)

  1. click OK.

by now you should have a "first" Title page with no number, and 14 pages with roman numbers.

now you want to change the roman numbers back to arabic, somewhere in the middle of the text.

to do that you must create a new page style, and then ... (more)

edit flag offensive delete link more

Question Tools



Asked: 2013-03-04 00:50:07 +0200

Seen: 97,581 times

Last updated: May 20 '18