Page numbering nightmare

What’s so hard to understand in LibreOffice Help - About Header and Footers and in your case to add the field to header since you want it “to appear in the upper right corner”?


@ajlittoz - Actually, I’ve been using Libre for more than 15 years. And while I don’t think it’s unreasonable to ask that LO be able to number pages of .doc/.docx files, the document I’m working with at the moment is in .odt. The problem, in other words, is not limited to non-native formats.

@anon87010807 - I wasn’t suggesting that all software must behave like Word; I just provided Word as an example of how this particular formatting challenge was successfully addressed long ago and thus, in theory, shouldn’t be an insurmountable problem for Libre. (The same might be said of footnotes/endnotes, but that’s a tale of angst for another day.) If, as you say, the issue I outlined can be solved “easily,” I await instructions for how to do so.

@anon73440385 - Why is my preferred placement for the page number (upper right) relevant here? Does that present a separate obstacle? Thanks for the document in which pg numbers appear. Any chance you can share directions for how I can replicate that?

@BlebNevus: Google is your friend. I wrote a tutorial once that covers some problems with page styles and page numbering. Your issue is covered there. It’s covered in many other discussions as well. All you have to do is search and carefully read instructions. I’m not going to repeat them here.

@BlebNevus: I don’t see any difficulty. Once you have enabled the header, you just Insert>Field>Page Number. Is this difficult?

Why is my preferred placement for the page number (upper right) relevant

Obviously it is relevant where to place the page field. No other meta information contained in my comment.

Any chance you can share directions for how I can replicate that?

No - because this kind of information is given in plenty of answers here, in LibreOffice Help, covered in Writer Guide and finally the solution in the sample file is obvious.

What’s so hard to understand in LibreOffice Help - About Header and Footers and in your case to add the field to header since you want it “to appear in the upper right corner ”?

What’s so hard to understand is that all responses are snarky and non-solutions.

I want—and the op wanted—to use a standard variant of standard page numbering schemes. But all one receives are snarky comments and “solutions” that are off-point, obscure, or wrong. LO is good, and I’ve had little or no trouble using it for months. All i want to do now is begin page numbering (123…) on the 2nd page, with the1st page unnumbered. How is this done, please? Step by step without omissions, and preferably w.out snarkiness. Thanks

The link in the first post above - How do I begin page numbers on page 2 in Writer to save you scrolling up again - pretty much gives you a step by step instruction; does this not work for you?

Whenever one asks for step-by-step instructions from other people (who supposedly are expected to sit and put some lengthy step-by-steps for someone with absolutely unknown skills with unknown situation, in a situation where the step-by-step explanations were already recorded in help, tutorials and FAQs, so obviously the questioner has something unknown not covered by the given steps), one simply must first sit and produce a good question, with own step-by-steps which don’t work for them, specific explanations what is their expectation on the problematic steps, and what exactly happens instead; screenshots where needed, and preferably the sample document where an answerer can see the problem. And then - yes, one could expect that they get a useful advise.

There are two points to consider:

  • page number is a property of page styles
    Consequently if you want an unnumberd group of pages and a numbered group, you nees two page styles.

  • page number is not a primary object you can lay out anywhere in the page. It is a field which is inserted in a paragraph
    Thus you must write down a paragraph which can be formatted to your liking, e.g aligned right to get the page number at top right in the page header.

Thanks for your reply, robleyd…yes I saw it, and here’s a “short” summary of what I’ve tried/headaches and where I am now: I didn’t/don’t see any Styles and Formatting icon, and I moused over everything, especially in what looked like the Formatting area. Under View-Toolbars, there’s Formatting(Styles), which I checked but I couldn’t find anything that led to a “Styles and Formatting window to open” …. the Help menu had similar dead ends for me, which would take pages to describe; it’s inexplicable that there’s not a simple 1 or 2 step process for getting to a menu that gets this done. My doc is an existing document formatted in a particular way (it has existing header and footer), in which I’m writing my own text, so I can’t Create a new doc, which is the first step in the instructions, but I’ve tried creating a new doc as a test, which had a different roadblock. I did double click on a page num in my existing header (pagenums are in header, not in footer), and a Edit Fields menu came up that looked promising, with an Offset box . I tried an offset of -1 and the first page was numbered zero, then 123 for succeeding pages, which was an acceptable solution. I saved the doc, but when I reopened it, the first page started with 1 again, which seems to be a definite bug. I redid the -1 offset and exported as pdf, and the nums start with zero on the pdf, which is what I’m happy with at this point. I could just check/redo the page numbs each time before saving as a pdf, but that could complicate things for me over time if I forget. I downloaded the PageNumExample.odt file, and that led me to selecting text on a page, then format, paragraph/textflow and that menu (which I’ve seen before) that has a Page number box with selector arrows for changing it (which I’d never noticed before), which seemed promising. But when I did the same thing on my doc, the Page number box was greyed out and not changeable. I also created a dummy 2-page doc, and the box was also greyed out. My current hope/question is if I can un-grey the Pagenumber box on textflow, I’m hoping that might finally, really solve this. I’m guessing there’s some lock/enable box somewhere for Pagenumber on textflow menu?? Not that I hold MSFT as a standard for much (though Excel is great and Word is good), I recall that beginning page numbers on a particular page is a simple box entry on the menu where you choose number-style, which does make this LO office “process” a relative nightmare. The Offset option on the Edit menu here, with the 1st page numbered zero, is good enough at this point (and is the logical place to put an actual BeginNumberingOnPage N box), and I’ll live with the bug on reopen if I can’t get an actual solution here…thx again, robleyd

Have you seen the “Sidebar”?
You may try this video:

Styles begin around 3:40, but how to switch this on may also be useful to you

If you don’t trust links, try google with :
youtube LibreOffice sidebar

Usually grey boxes show “this is a field”, so filled from some source/by some rule. Therefore you may change/adapt the source and rules, but “editing” is actually removing the field and replacing with text. Maybe you have used the field for the current date sometime…

Don’t do that! The Offset parameter don’t change the page number but references a different page. If the page doesn’t exist the returned number is “void”. This feature is the base for insertions like see next page which is suppressed if you are already at last page.

These “textflow” parameters appear either in the Text Flow tab of a paragraph style or as properties of Insert>More Breaks>Manual Break. You change the behaviour of page numbering only with a (special) page break. Enable the break and you can force the page number to any value.

the basic, simple solution to your request is:

  • With a default page setup (no changes made to page styles), insert a page header.
    According to what you have stated before, you already did this.
  • In the page header, insert a field for page number
    According to what you have stated before, you already did this.
  • Enable the “special” First page style.

It is rarely a good idea to use the offset option for the page number. This option does not change the page number. It only adjusts the number displayed. If you create a ToC or index, the entries will use the actual page numbers, not the numbers created by offset.

Detailed steps, in case they are required.

  • insert a page header
    Menu selection Insert-Header and footer …-Header-Default page style
  • insert a field for page number
    • Double click inside the header area to enable editing of header
    • Hit the tab key twice to move far right (by default a header has two tab stops: one center-tab in the middle and one right-aligned at the right margin)
    • Menu selection Insert-Page number
  • Enable the First page style.
    • Double click in text area (not header)
    • Activate the right side panel
      Select Sidebar or side panel on the View menu
    • Select the Styles tool on the panel
      Click the styles (second) icon in the vertical toolbar, far right on the side panel
    • Select to work with page styles
      Click the page styles (fourth) icon on the toolbar above the side panel.
    • Double click the First page entry to activate it.

thanks keme1. i was making do with the negative offset because it numbered correctly and looked fine, and bc i had to get this initial phase done and couldn’t mess with edit fields, pages styles, properties and whatever, which weren’t working—at least on my pre-formatted doc—for what should be a trivial mod that Word does with one click. (Again, I’m not fan of MSFT, but a word processor is supposed to be a productivity tool, and why anyone should be forced to jump through these hoops for a basic op is inexplicable.)

i copied my doc into a blank doc, for reasons other than this pagenum issue, and I called up the Styles menu you describe. I Inserted pagenums, then clicked and double-clicked First Page; that didn’t change page 4 to 1. I undid it, closed the menu, called up the menu, clicked/dc First Page, then Insert pagenum; no dice. Here’s a screenshot link.

do you see what i don’t? -thx

Yes I see what you don’t see and also what I didn’t see. :blush:

My answer was based on the original question, not your comment about a similar issue.

The original question specifically requests:

Your request, in a comment to this question which I did overlook, is contained in one sentence:

This should do to reset actual page numbering by direct formatting in your existing document:

  • Go to the first paragraph of page 2 and select menu item:Format - Paragraph
  • Select the Text flow tab
  • In the Breaks section
    • tick Insert
    • Select type Page
    • Tick With page style and select your style (probably preselected.
    • Tick Page number and enter 1

This can also be done by linked paragraph and page styles, so everything is more or less automated. (Styles is the preferred way, but it is an additional level of abstraction which may be confusing at first, which is why I have given the “quick and dirty” solution.)
If you envision creating a lot of documents with the same pagination flow, I strongly encourage you to create a template with such styles. Ask here when you get stuck. (with a new question, not further commenting on this one.)

… which is why all this discussion here is very bad, @ksilver effectively hijacked the original Q&A by a different problem, making the whole Q&A much less useful for people looking for answers - because now it’s very difficult to understand which suggestion solves which problem…

What is so difficult in creating own questions, and if needed, adding links there to other existing questions that the asker tried, to inform potential answerers about the context? :frowning:

1 Like

Thanks, keme1!..this did make my targeted page, Pagenum 1. The previous pages are still numbered, however (the first page in the section of previous pages doesn’t have a number), and at this point, I just want NO pagenums in that first section. I clicked in a page # in the first section, pressed delete, but all the page nums in the doc. were deleted. I’ve tried a few things in the Textflow menu in the first section, but no luck. I’d think there’s a way of eliminating pagenums in the first section while preserving the pagenums in the second section (now starting with Page 1)…thanks again

ksilver, please upload your ODF type sample file here.