Ask Your Question
0

writer: table of contents, 2 columns

asked 2017-11-26 20:12:58 +0200

wacole1213 gravatar image

updated 2017-11-28 17:39:20 +0200

Jim K gravatar image

Using Writer 5.3.6.1 with Window 10.

When displaying a Table of Contents [ToC] in two columns the leaders on entries below level 1 do not display in the first column only. They display properly in the 2nd column. I was going to attach a file showing the anomaly but I don't have enough points. This looks like a bug to me, but maybe I'm doing something wrong. Would be grateful for advice.

EDIT:

Now that I have this mostly straightened out [thank you for the help], there is still the matter of indents that have disappeared. Below are two previews from two different ToCs. The first one, labeled API, does not show indented headings. The second one labeled PI, does. I've compared the ToC settings of the two, but for the life of me cannot see what I've missed that would yield this difference.

Advice, please.

Thanks, Bill Cole

image descriptionimage description

edit retag flag offensive close merge delete

Comments

You can always post files at sites like www.mediafire.com that don't require registration for people to download files offered there (you will have to register to upload something there, though).

floris v gravatar imagefloris v ( 2017-11-26 21:13:56 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2017-11-26 22:03:21 +0200

ajlittoz gravatar image

updated 2017-11-27 19:02:15 +0200

Your problem is related to tab position for page number. This happens the same in all ToC or Index tables.

See my answer in this question.

EDIT after the question in your own answer

General aspect of TOC entries are controlled by paragraph styles Contents 1 to Contents 10 where the number relates to entry level. Maybe you fiddled with these styles and you erased the indent. To set one to your taste, modify said styles in Indents & Spacings tab of change dialog.

Styles are accessed with the style panel (F11 to display it), right-click on a name and select Modify… from the drop-down menu.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

Your answer got me most of the way there. The leaders are now back and the page number alignment is correct. However, I have lost the Level-based indent.

wacole1213 gravatar imagewacole1213 ( 2017-11-27 17:33:11 +0200 )edit

The indents are controlled in the Contents1, Contents2, etc. paragraph styles. Press F11 to open the Styles overview, make sure that styles in use are displayed, find the Contents styles, right click and select Modify, on the tab Indents and Spacings you can then set a value in Before text. Note that these styles are applied automatically, you just have to change the formatting details, you don't have to apply the styles yourself.

floris v gravatar imagefloris v ( 2017-11-27 19:20:52 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-11-26 20:12:58 +0200

Seen: 201 times

Last updated: Nov 28 '17