Documented method to restart page numbering in master documents does not work

asked 2017-12-05 12:49:01 +0100

kkaliotis gravatar image

updated 2017-12-06 21:06:01 +0100

Jim K gravatar image

This has been asked before, but it was never answered.

The last LO Writer guide (p. 389 in the PDF) mentions that in order to restart page numbering inside a master document one needs to create a heading style with outline level set to Level 1 and which inserts a page break with a specific page style and sets the page number to 1.

I have created such a heading style in my document's template, but page numbering does not restart.

If I apply the same style to a paragraph of a regular document, it works.

Any ideas?

(using v5.4.3.2)

EDIT:

Hi Jim,

Unfortunately my ISP is having problems at the moment and it would take forever to upload my thesis at my current speed. I'll try to explain what I have done.

I started by creating a template and from that template the master document and all the sub-documents.

Whenever I wanted to add or modify a style, I did it in the template and the files were updated the next time they were opened.

I wanted the numbering to restart with Arabic numerals at the preface, which is a sub-document.

I created a heading style with its outline level set to Level 1. In the "Text Flow" tab I have the style insert a page break before it, with a specific page style and the page number set to 1.

All the sub-documents and the master document were updated to use the newer version of the template and I set the very first paragraph of the preface to that heading style.

In the master document, the numbering will not restart. If I apply the heading style somewhere in a sub-document (or a new document from that template), it does. It also restarts if I apply the heading style to a later part of the preface sub-document, but not to the first line. Although in that case, my first preface page gets the number 0… I can only get it to work if I add a blank page before the actual first page of the preface.

edit retag flag offensive close merge delete

Comments

Cannot reproduce the problem. When I added a new heading as instructed, it correctly restarted page numbering to 1. Can you upload an example file? It needs to be on a different site since you do not have enough points to attach files here yet. Alternatively, provide the exact steps needed to reproduce the problem starting from an empty master document.

Jim K gravatar imageJim K ( 2017-12-05 18:55:36 +0100 )edit

Can you make a simple example that illustrates the problem? One way would be to make a copy of the document and then keep deleting content until it is only one or two pages showing the problem. From https://ask.libreoffice.org/en/questi...: "Simplify and isolate the problem as much as possible... Give all information and steps necessary to reproduce the problem.

Jim K gravatar imageJim K ( 2017-12-06 21:27:36 +0100 )edit

I have uploaded my template here. What I ended up doing was creating an "invisible" heading style outside the outline numbering (Heading 1 Chapter 1), set to insert a page break with page number 1. Right after that page, I have a page starting with the "Heading 1" paragraph style, which -miraculously- has a page number of 1…

kkaliotis gravatar imagekkaliotis ( 2017-12-08 01:06:38 +0100 )edit