Problem adding characters from unicode with autoext and autocorrect

asked 2018-03-04 18:46:13 +0200

Ometeotl gravatar image

Hi fellas

I'm writing this after battling for literally six hours non-stop with a problem that has me exhausted. I'm trying to add superior and inferior "affixes" to my characters, the affixes are designed as zero-width combining diacritical marks in unicode. The fonts are ancient maya glyphs and there's hundreds of them so I can't map directly every character to a letter, I must use shortcuts like ku1 or ma4, think a little bit like chinese

The problem is that if I write the unicode directly (say F665A) and then I press alt+x there is no problem, the symbol is exactly where it is supposed to be, on the character, but when I use the autotext feature the diacritic is slightly to the right of character, the same with autocorrect. In latin letters I would like wanting something like this ä but instead i get a¨ (where both [a] and [¨] are unicode characters originally), I hate that to write RU1 KU3 I have to write all the time F6348 and F62D5 instead of using either autocorrect or autotext ku1 ru1 I mean, there is no way I can write much like this. Can you help me? I think I tried everything, I even downloaded autokey but again the same problems.

edit retag flag offensive close merge delete

Comments

Be more specific. What character(s) are you trying to insert? Which font(s) are you using? The problem may be about the font(s). I. e. improve your question.

gabix gravatar imagegabix ( 2018-03-05 07:31:31 +0200 )edit

What Maya font file are you using?
I would like to download and test myself.
See what is happening.
See if there is a solution or workaround.

LibreTraining gravatar imageLibreTraining ( 2018-03-05 23:00:58 +0200 )edit