Ask Your Question
1

Libre 4.0 writer crashes ALOT running on MAC OSX.7.4 [closed]

asked 2013-03-19 20:34:42 +0200

jbushey gravatar image

updated 2015-10-29 15:55:24 +0200

Alex Kemp gravatar image

I am running Libre Office 4.0 on MAC OSX.7.4 and using writer for text documents. I save often, but I find that Libre crashes at least every couple hours. The data is always recovered, but of course, not the changes I made after my last save. I have submitted a problem report for LibreOffice, but no help yet.

I'm simply typing sentences and paragraphs, no charts, no calculations etc.. But I do notice that sometimes, as I'm typing a weird character will appear, maybe Japanese? and then disappear as I continue to type.

Has anyone else experienced this problem? Is this a Java problem? Does anyone have a fix, cause it is really annoying.

Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-29 15:55:52.049196

4 Answers

Sort by » oldest newest most voted
0

answered 2013-03-20 09:34:04 +0200

qubit gravatar image

updated 2013-04-08 09:34:30 +0200

Hi @jbushey,

You mentioned filing a bug already -- could you please provide a link to it?

It sounds like you're running one of the latest builds. If you're not yet on LO 4.0.1, it wouldn't hurt to try the latest release.

If you can find some steps that will reproduce a crash that could really help us, although it sounds like you're just experiencing sporadic crashes, eh?

Thanks!


Resolving as Bug Filed: https://bugs.freedesktop.org/show_bug.cgi?id=62619

edit flag offensive delete link more

Comments

1

I will try updating to 4.0.1, but I agree with kbares/user that the crash happens when I type fast. Also I noticed that when I am typing I sometimes see (very briefly) a Japanese or maybe Chinese character in my line of text. It disappears quickly and doesn't always signal a crash. I should clarify that I am typing in English. I apologize for not attaching the bug report. I will the next time it crashes.

jbushey gravatar imagejbushey ( 2013-03-21 20:45:26 +0200 )edit

Ok. it just happend again. I was working in Writer with 2 different documents open, but only typing into one of them. I typed a word, hit the back space/delete a couple times and then started to type again. CRASH. I can't figure out how to attach my crash report to this interface? help.

jbushey gravatar imagejbushey ( 2013-03-22 00:02:20 +0200 )edit

@jbushey -- I'm not seeing a link to the bug report. Could you please try again?

Thanks!

qubit gravatar imagequbit ( 2013-03-22 00:08:56 +0200 )edit

Sorry but I cannot understand how to attach/link my file to this forum. I hit link and I see an orange flashing page. I've searched the forum for instructions on how to link a crash report and found nothing.

jbushey gravatar imagejbushey ( 2013-03-22 00:17:47 +0200 )edit

@jbushey, Please attach the crash report to a bug report on Bugzilla. Here's the link to file a bug

qubit gravatar imagequbit ( 2013-03-22 00:35:18 +0200 )edit

@jbushey -- if you're having trouble with the BSA (Bug Submission Assistant), please try to submit a bug directly to Bugzilla at this link

qubit gravatar imagequbit ( 2013-03-22 01:20:10 +0200 )edit
1

ok. here is the link to the bug report: https://bugs.freedesktop.org/show_bug.cgi?id=62619 i named it fileopen, but that isn't really accurate. i attached the Apple crash report in the bug.

jbushey gravatar imagejbushey ( 2013-03-22 01:53:52 +0200 )edit
1

i just added another crash report to the bug report i created. hopefully that will help the developers solve what is going on.

jbushey gravatar imagejbushey ( 2013-03-23 21:08:44 +0200 )edit
1

answered 2013-03-21 19:36:25 +0200

kbares gravatar image

updated 2013-03-21 19:37:31 +0200

Hi, LO 4.0.1.2 is crashing fairly frequently (2-3 times per day) for me on OSX 10.7.5. Most recent appeared to be when I was typing rapidly. Crash report attached. Thanks!

crash21mar13.odt

edit flag offensive delete link more
0

answered 2013-04-08 14:13:24 +0200

froz gravatar image

updated 2013-04-08 14:16:01 +0200

This is not a solution to your problem, but to minimize data lost, do the following (you know problem may not be solved soon, but you get annoying data losts):

Tools | Options | Load/Save. Make sure "Save AutoRecovery information" is checked and try lowering the default 15 minutes to 5 minutes or less.

You can also check the "Always create a backup copy" to make extra save every save action.

edit flag offensive delete link more
0

answered 2013-03-25 16:03:49 +0200

annebl gravatar image

I don't see any Chinese characters, but my Lib Writer keeps crashing too.

Here's my crash report:

Process: soffice [288] Path:
/Applications/LibreOffice.app/Contents/MacOS/soffice Identifier:
org.libreoffice.script Version:
4.0.1.2 (???) Code Type: PPC (Translated) Parent Process: launchd [96]

Date/Time: 2013-03-25 15:59:48.785 +0100 OS Version:
Mac OS X 10.6.8 (10K549) Report Version: 6

Interval Since Last Report:
13976170 sec Crashes Since Last Report: 50 Per-App Interval Since Last Report: 297137 sec Per-App Crashes Since Last Report: 5 Anonymous UUID:
2C434076-0284-4E42-A784-85FD8AAC4796

Exception Type: EXC_CRASH (SIGABRT) Exception Codes: 0x0000000000000000, 0x0000000000000000 Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Thread 0 Crashed: Dispatch queue: com.apple.main-thread 0
org.libreoffice.script
0xb815ac07 spin_lock_wrapper + 89967 1 org.libreoffice.script
0xb8179fb4 CallPPCFunctionAtAddressInt + 98620 2 org.libreoffice.script
0xb80c6b13 0xb8000000 + 813843 3
org.libreoffice.script
0xb80c0037 0xb8000000 + 786487 4
org.libreoffice.script
0xb80dd8e8 0xb8000000 + 907496 5
org.libreoffice.script
0xb8145397 spin_lock_wrapper + 1791 6 org.libreoffice.script
0xb801ceb7 0xb8000000 + 118455

Thread 1: 0 libSystem.B.dylib
0x80142afa mach_msg_trap + 10 1
libSystem.B.dylib
0x80143267 mach_msg + 68 2
org.libreoffice.script
0xb819440f CallPPCFunctionAtAddressInt + 206231 3 libSystem.B.dylib
0x80170259 _pthread_start + 345 4
libSystem.B.dylib
0x801700de thread_start + 34

Thread 2: 0 org.libreoffice.script
0xb815a93a spin_lock_wrapper + 89250 1 org.libreoffice.script
0xb8176f67 CallPPCFunctionAtAddressInt + 86255 2 org.libreoffice.script
0xb80c6b13 0xb8000000 + 813843 3
org.libreoffice.script
0xb80c0037 0xb8000000 + 786487 4
org.libreoffice.script
0xb80dd8e8 0xb8000000 + 907496 5
org.libreoffice.script
0xb8145397 spin_lock_wrapper + 1791 6 org.libreoffice.script
0xb801ceb7 0xb8000000 + 118455

Thread 3: 0 org.libreoffice.script
0xb815acc0 spin_lock_wrapper + 90152 1 org.libreoffice.script
0xb8179c5b CallPPCFunctionAtAddressInt + 97763 2 org.libreoffice.script
0xb80c6b13 0xb8000000 + 813843 3
org.libreoffice.script
0xb80c0037 0xb8000000 + 786487 4
org.libreoffice.script
0xb80dd8e8 0xb8000000 + 907496 5
org.libreoffice.script
0xb8145397 spin_lock_wrapper + 1791 6 org.libreoffice.script
0xb801ceb7 0xb8000000 + 118455

Thread 4: 0 org.libreoffice.script
0xb815ac07 spin_lock_wrapper + 89967 1 org.libreoffice.script
0xb8183076 CallPPCFunctionAtAddressInt + 135678 2 org.libreoffice.script
0xb80c6b13 0xb8000000 + 813843 3
org.libreoffice.script
0xb80c0037 0xb8000000 + 786487 4
org.libreoffice.script
0xb80dd8e8 0xb8000000 + 907496 5
org.libreoffice.script
0xb8145c1d spin_lock_wrapper + 3973 6 org.libreoffice.script
0xb801ceb7 0xb8000000 + 118455

Thread 5: 0 org.libreoffice.script
0xb815a8c8 spin_lock_wrapper + 89136 1 org.libreoffice.script
0xb8176d61 CallPPCFunctionAtAddressInt + 85737 2 org.libreoffice.script
0xb80c6b13 0xb8000000 + 813843 3
org.libreoffice.script
0xb80c0037 0xb8000000 + 786487 4
org.libreoffice.script
0xb80dd8e8 0xb8000000 + 907496 5
org.libreoffice.script
0xb8145397 spin_lock_wrapper + 1791 ...

(more)
edit flag offensive delete link more

Comments

@annebl -- Please post crash reports as comments/attachments on the bug report fdo#62619.

Thanks!

qubit gravatar imagequbit ( 2013-03-25 16:51:44 +0200 )edit

I have checked bug reports and I see bug reports are different (diff) and also appearing different errors and also at different LibreOffice version. I think the best way is to open a new bug report, attach crash reports and in post message write that behavior is very similar (the same) as bug 62619. Then administrators of bug system will check if this is the same problem and if yes make links of duplicate bugs. I think posting several bug reports with different problem makes mess in bug reports.

froz gravatar imagefroz ( 2013-04-08 14:33:11 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2013-03-19 20:34:42 +0200

Seen: 1,603 times

Last updated: Apr 08 '13