Ask Your Question
1

Spell checker not working on Docs created from desktop or folder [closed]

asked 2013-03-28 18:39:43 +0100

Nig67 gravatar image

updated 2015-08-24 17:51:43 +0100

Alex Kemp gravatar image

I appear to be unable to spellcheck (auto-spell or manual check) documents created by a right-click from the user's desktop or from a folder, in Windows (Vista/7) 64-bit - and I get the same problem with both LibreOffice and with OpenOffice. Spellcheck still works correctly when launching Writer first, then creating a new document.

Try this:

Move mouse pointer to blank space in a folder or move mouse pointer to blank space on the user's desktop.

Right click mouse.

Select New, then select OpenDocument Text.

Hit return or enter a file name for this document, then hit return.

Double click the new document you have created to open your document in (OpenOffice or) LibreOffice Writer.

In Writer, type random text (ie text that would produce spelling error, 'ghgy' will do).

press Return.

Text not highlighted with red wavy line as being misspelt.

Check document spelling manually and no spelling errors are detected.

Close your document and LibreOffice, then try this:

Launch LibreOffice and start new Text Document. Here, type in misspelt word, followed by pressing Return, and the error is automatically discovered by LibreOffice. Why does spellcheck work in one instance but not the other?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-27 20:13:56.064095

2 Answers

Sort by » oldest newest most voted
0

answered 2013-03-28 19:25:14 +0100

manj_k gravatar image

Please have a look at my answer in
When I'm starting program it is no language to check spelling,
and try the described workaround; see also Related links.

edit flag offensive delete link more

Comments

I tried your workaround (prefered language pack English(UK) on both FAT32 and NTFS file systems). Unfortunately, this does not appear to be a solution to my question. After setting language pack and setting this blank document as a default Template, subsequent Text files created from this Template, in the way I described in my question would show "None" in the modified default languages for documents field and the spellcheck (manual/auto) still does not show up known misspelt words.

Nig67 gravatar imageNig67 ( 2013-03-30 19:12:08 +0100 )edit

Do you have replaced "soffice.odt"(Step 2) / (Step 2 for LibreOffice 4.0)?

Please, could you upload this customized file for testing?

manj_k gravatar imagemanj_k ( 2013-03-30 19:40:33 +0100 )edit

Sorry, I also experienced problems with step 2 of your workaround. I was unable to mention this in my earlier comment as I would have exceeded the character limit for comments.

Basically, I was unable to find “soffice.odt” and “C:\Users\All Users\Templates” ANYWHERE on my computer, even after logging on as the Administrator and searching for this file and directory.

Nig67 gravatar imageNig67 ( 2013-03-31 15:13:12 +0100 )edit

What I did instead was to create the template in step 1, BUT following that I saved this under a completely different name to the default name and then assigned this MyName.odt file as the default.

I do not know where that would be saved or even how to upload that file. Yes its LibreOffice 4.0.1.2

Nig67 gravatar imageNig67 ( 2013-03-31 15:14:20 +0100 )edit

@Nig67 – (1) Please have a look at my update → (Step 2 for LibreOffice 4.0).

manj_k gravatar imagemanj_k ( 2013-03-31 15:32:03 +0100 )edit

@Nig67 – (2) To create/save a template → "Save as Template" failed due to "Template Manager"

(3) To set a template as the default template → Change default template in Writer (LibreOffice 4)

manj_k gravatar imagemanj_k ( 2013-03-31 15:54:55 +0100 )edit

@Nig67 – (4) The path of your templates is shown in the menu "Tools → Options → LibreOffice → Paths → Templates".

See also → TDF wiki · LibreOffice user profile.

manj_k gravatar imagemanj_k ( 2013-03-31 16:07:52 +0100 )edit
1

Fantastic!! The updated Step 2 for LibreOffice 4.0 does the trick. I am now able to spell check files created by the mouse right-click.

Nig67 gravatar imageNig67 ( 2013-04-01 13:06:24 +0100 )edit

@Nig67 – Thanks for your feedback ... :)

manj_k gravatar imagemanj_k ( 2013-04-01 16:58:08 +0100 )edit
0

answered 2013-03-28 19:02:02 +0100

bllgvn gravatar image

I tested this on my system with Windows8 and Libre Office 4.0.1 and I'm seeing the same behavior. I would recommend filing a bug report if this is behavior you would like

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-28 18:39:43 +0100

Seen: 3,765 times

Last updated: Mar 28 '13