Ask Your Question
1

Installation of LanguageTool in Ubuntu18.4 [Solved]

asked 2018-06-09 10:50:19 +0200

PèreOrval gravatar image

updated 2018-06-09 16:41:37 +0200

I made a fresh installation of Ubuntu18.4. When trying to install LanguageTool In LO 6.0.3.2, the installer returns always an error (See bottom). I tried various jre's : default one, openjdk8, oracle jre and ibm jre. I tried also different versions of LT : 3.9, 4.0, 4.1. The installation of eg. Grammalecte is fine.

I'm encountering the same issue with the beta-version of LinuxMint 19.1 (which is a derivative of Ubuntu18.4). The weird thing is that installing LanguageTool in LM18.3 and LO 6.0.3.2 is ok. So I guess that the issue must be located in one of the Ubuntu18.4-packages.

Is there a way to figure out where the problem is located?

Blockquote com.sun.star.uno.RuntimeException) { { Message = "[jni_uno bridge error] UNO calling Java method writeRegistryInfo: non-UNO exception occurred: java.lang.NoClassDefFoundError: com/sun/star/task/XJobExecutor\X000ajava stack trace:\X000ajava.lang.NoClassDefFoundError: com/sun/star/task/XJobExecutor\X000a\X0009at java.base/java.lang.ClassLoader.defineClass1(Native Method)\X000a\X0009at java.base/java.lang.ClassLoader.defineClass(ClassLoader.java:1009)\X000a\X0009at java.base/java.security.SecureClassLoader.defineClass(SecureClassLoader.java:174)\X000a\X0009at java.base/java.net.URLClassLoader.defineClass(URLClassLoader.java:545)\X000a\X0009at java.base/java.net.URLClassLoader.access$100(URLClassLoader.java:83)\X000a\X0009at java.base/java.net.URLClassLoader$1.run(URLClassLoader.java:453)\X000a\X0009at java.base/java.net.URLClassLoader$1.run(URLClassLoader.java:447)\X000a\X0009at java.base/java.security.AccessController.doPrivileged(Native Method)\X000a\X0009at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:446)\X000a\X0009at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:566)\X000a\X0009at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:553)\X000a\X0009at java.base/java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:890)\X000a\X0009at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)\X000a\X0009at com.sun.star.comp.loader.RegistrationClassFinder.find(RegistrationClassFinder.java:53)\X000a\X0009at com.sun.star.comp.loader.JavaLoader.writeRegistryInfo(JavaLoader.java:376)\X000aCaused by: java.lang.ClassNotFoundException: com.sun.star.task.XJobExecutor\X000a\X0009at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:466)\X000a\X0009at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:566)\X000a\X0009at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)\X000a\X0009... 15 more\X000a", Context = (com.sun.star.uno.XInterface) @0 } }

edit retag flag offensive close merge delete

Comments

1

There is something like your issue in this Q&A on AskUbuntu - does the solution there work for you?

David gravatar imageDavid ( 2018-06-09 16:10:27 +0200 )edit
1

David, you saved my day! I only needed to install libreoffice-common-java and the extension could be installed without any problems. Thanks a lot.

PèreOrval gravatar imagePèreOrval ( 2018-06-09 16:40:56 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-06-09 16:46:57 +0200

David gravatar image

updated 2018-06-09 16:48:53 +0200

This problem came up on AskUbuntu. The solution was to install this package, using the syntax for 18.04:

   sudo apt install libreoffice-java-common

The installation of the "LanguageTool" should then be successful.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-09 10:50:19 +0200

Seen: 633 times

Last updated: Jun 09 '18