Installation of LanguageTool in Ubuntu18.4 [Solved]

I made a fresh installation of Ubuntu18.4. When trying to install LanguageTool In LO, the installer returns always an error (See bottom). I tried various jre’s : default one, openjdk8, oracle jre and ibm jre. I tried also different versions of LT : 3.9, 4.0, 4.1. The installation of eg. Grammalecte is fine.

I’m encountering the same issue with the beta-version of LinuxMint 19.1 (which is a derivative of Ubuntu18.4). The weird
thing is that installing LanguageTool in LM18.3 and LO is ok. So I guess that the issue must be located in one of the Ubuntu18.4-packages.

Is there a way to figure out where the problem is located?

Blockquote { { Message = “[jni_uno bridge error] UNO calling Java method writeRegistryInfo: non-UNO exception occurred: java.lang.NoClassDefFoundError: com/sun/star/task/XJobExecutor\X000ajava stack trace:\X000ajava.lang.NoClassDefFoundError: com/sun/star/task/XJobExecutor\X000a\X0009at java.base/java.lang.ClassLoader.defineClass1(Native Method)\X000a\X0009at java.base/java.lang.ClassLoader.defineClass(\X000a\X0009at java.base/\X000a\X0009at java.base/\X000a\X0009at java.base/$100(\X000a\X0009at java.base/$\X000a\X0009at java.base/$\X000a\X0009at java.base/ Method)\X000a\X0009at java.base/\X000a\X0009at java.base/java.lang.ClassLoader.loadClass(\X000a\X0009at java.base/java.lang.ClassLoader.loadClass(\X000a\X0009at java.base/\X000a\X0009at java.base/java.lang.ClassLoader.loadClass(\X000a\X0009at\X000a\X0009at\X000aCaused by: java.lang.ClassNotFoundException:\X000a\X0009at java.base/\X000a\X0009at java.base/java.lang.ClassLoader.loadClass(\X000a\X0009at java.base/java.lang.ClassLoader.loadClass(\X000a\X0009… 15 more\X000a”, Context = ( @0 } }

There is something like your issue in this Q&A on AskUbuntu - does the solution there work for you?

David, you saved my day! I only needed to install libreoffice-common-java and the extension could be installed without any problems. Thanks a lot.

This problem came up on AskUbuntu. The solution was to install this package, using the syntax for 18.04:

   sudo apt install libreoffice-java-common

The installation of the “LanguageTool” should then be successful.