Ask Your Question
0

How to fix indent above the endnotes?

asked 2018-07-02 20:27:35 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

This indents appears on each single page where endnotes were presented, but it is normally presented on the pages with the main text. image description

The main problem is that on the page where Endnotes were presented as two columns, appears some mysterious indent. Look at the image below.

image description

When I change the number of columns on the current page from two to one - this had fixed the indent and looked properly. Image below.

image description

Then, if I try to come back to two column style it dosen't work yet. See image below.

image description

All this manipulations I've made in the .odt file. Instead of this when I import this file (without any described above manipulations, when the file include two columns setting and huge indent) in the .docx and open it with the Word - the artifact disappears. See image below.

image description.

So the question is how to remove this indent and save two columns style? Thanks

C:\fakepath\part1-.odt

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-07-05 10:07:45 +0200

Mike Kaganski gravatar image

updated 2018-07-05 10:43:35 +0200

This definitely looks like a bug, so I advise you to file a report.

I can only suggest the following workaround: use the section's Endnotes/Collect at end of section feature this way:

  1. Select all the normal text, and InsertSection.
  2. In the dialog's Footnotes/Endnotes tab, check Collect at end of section checkbox; click OK.
  3. The endnotes now start right after the text, not on a separate page; they have separator lines at the top of their columns.
  4. Remove the separators: in the page's style, go to Footnote (sic!) tab, and select [None] style. OK.
  5. Since your endnotes are not starting on own page, the only trick I have to do that is to add a new paragraph at the end of the normal text, (optionally apply an appropriate heading style,) and set it to have page break before. Let the paragraph be the endnotes' heading (put something like "Notes" text to it).

This is the result of the steps above. Of course, you may also want to play with spacing settings at the step 4.

edit flag offensive delete link more

Comments

Well, It is strange way out, maybe not properly but it works. I reported a bug already.

username gravatar imageusername ( 2018-07-05 15:50:11 +0200 )edit
0

answered 2018-07-02 21:05:48 +0200

ajlittoz gravatar image

Endnotes are collected in their own pages controlled by page style Endnote.

Check to see how margins and other layout elements, such as header or footer, are configured in Endnote. You may also have changed default settings in Tools>Footnotes & Endnotes. Go to Endnotes tab and see what page style is selected by drop-down menu Page. If it is not Endnote, reset it.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

After changing all possible settings I've identified that this indent appears just if in the page style endnote settings you use two or more columns. If I import the document in .docx and open it with Word the text in endnote page displayed normal. Moreover if I change from two to one column and click Appear or Ok it changes immediately, but it doesn’t work on the contrary instead of this column settings completely stop working. So I suppose this is a code-bug.

username gravatar imageusername ( 2018-07-03 10:09:16 +0200 )edit

Something else must be broken: here, 2-column index works fine. Does it happen when document is saved as .odt? .docx is known to have severe compatibility issues.

ajlittoz gravatar imageajlittoz ( 2018-07-03 11:21:04 +0200 )edit

I've changed the main text.

username gravatar imageusername ( 2018-07-04 00:04:23 +0200 )edit

If file does not contain confidential data, please attach it for technical analysis.

ajlittoz gravatar imageajlittoz ( 2018-07-04 06:48:21 +0200 )edit

I rewrote the data (did not affect the problem) and attached the file at the end of the post.

username gravatar imageusername ( 2018-07-04 09:22:31 +0200 )edit

Had a quick look on the file, saw nothing unusual but for a separator line which is normally used with footnotes, not endnotes.Could not get rid of it. This might be a clue: a confusion somewhere between end/foot-notes. XML seems OK but I'm no guru (nor developer).

ajlittoz gravatar imageajlittoz ( 2018-07-04 16:51:06 +0200 )edit

Though the problem is in the version of program so I tried to install Windows version of libreoffice. But indent still appears without the separator line. Maybe you're right, because after conversion in .docx Word insert at this place separator line as I presented on image above. Actually I tried to find a button to one-off the separator line for endnotes and found nothing, seems the button doesn't exist.

username gravatar imageusername ( 2018-07-04 18:22:36 +0200 )edit

I'm on Linux. Your original file displays with a very wide spacing as in your first 2 screenshots. If I play a bit with settings, I get your 3rd screenshot without spacing but with horizontal separator line.

If I write a doc from scratch, everything OK. Then it must be something which carried over from update to update. The strangest thing is I can no longer go back to multi-column once I've put your doc in 1-column.

ajlittoz gravatar imageajlittoz ( 2018-07-04 21:19:19 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-07-02 20:27:35 +0200

Seen: 53 times

Last updated: Jul 05