Ask Your Question
0

Numbered list with intervening unnumbered lines

asked 2018-08-09 04:14:02 +0200

lomacar gravatar image

For the paper I am writing I need to frequently have numbered lists with a second level using letters. Additionally there needs to be a second line beneath each "numbered" line, like so:

(1) 
    a. Item 1 (style: "Ex. Set")
       Comment (style: "Ex. Set Trans")
    b. Item 2
       Comment

The Ex. Set Trans style is set up to have the Ex. Set style come after it. The problem I am having is that after the Ex. Set Trans style, LibreOffice forgets that it is in a sub list and starts the next line with (2), at the first level. So I always have to hit tab to make it go to the second level. This is not a big deal but it is annoying and I want to have a template based on this for colleagues to use, many of which are switching over from Word, and I want everything to work as smoothly as possible.

One thing I tried was making Ex. Set Trans use the same numbered list style as Ex. Set and then checking off "Include this paragraph in line numbering." That fixes the problem of Ex. Set forgetting it's indent level, however now it forgets about numbering (ie. putting the letters a., b., c., etc. in front). The Ex. Set Trans style has the attribute "don't count lines" and I got the attribute "Count lines" on the Ex. Set style... Actually now that I test again, it is putting numbering on all the lines. Weird.

Is there a way to make it so that when hitting Enter on a Ex. Set. Trans line and starting a new Ex. Set line it will remember the right indentation level AND numbering? (And have Ex. Set Trans not display numbering.)

edit retag flag offensive close merge delete

Comments

Line numbering has nothing to do with lists. It displays a number once every n lines (n customisable) to the left. This number restarts on every page. Line numbering can be considered as "external" to your text, kind of space housekeeping. Don't count lines is also part of this feature to exclude paragraphs. Line numbering is sometimes a requirement from publishers.

ajlittoz gravatar imageajlittoz ( 2018-08-09 08:08:03 +0200 )edit

@lomacar: I still wonder if you regard the funadmental difference between the terms "line" and "paragraph". (The issue started with previous questions of yours.)
I would beg you for a clear statement insofar, and for exclusively using the correct term in every case.
Did you make sure you are shown all the available Options>LibreOffice Writer>Formatting Aids>Display of?

Lupp gravatar imageLupp ( 2018-08-09 10:23:44 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2018-08-09 04:27:51 +0200

lomacar gravatar image

updated 2018-08-10 04:07:40 +0200

OK, I immediately came up with a solution. I just made both styles use different numbered lists. I updated the second list style to match the first one. Then on the Customize tab I set Numbering to "None". Then I typed a space into the Before field. This caused the Ex. Set Trans line to pop into the correct alignment with the Ex. Set line.

Kind of hacky, but it works!

UPDATE: That solution has a kind of undesirable behaviour in that if you try to delete the Ex. Set Trans line by hitting backspace it won't work. You have to use the left arrow key first to go to the other side of the invisible numbering and then you can backspace or delete.

An alternative option is to set the Ex. Set Trans numbering style to Bullet and then use a space as the bullet symbol. This does allow to backspace a line away although it still requires an extra backspace to delete the invisible bullet.

UPDATE 2: Argh! Now it is not working for some reason! It is switching paragraph styles correctly, but it doesn't switch to the correct list style associated with that paragraph style. ?!?!?! It looks like it only happens when I have an frame (anchored as character) on the Ex. Set line. But unfortunately, I will always have such frames on the Ex. Set line in my paper... Weird I didn't notice this problem before.

edit flag offensive delete link more

Comments

Works for me with As Character frames, but behaves unexpectedly with "To character* inserted when typing. Probably caused by the fact that we can't easily put the cursor easily after the frame. So check you use the correct frame type.

ajlittoz gravatar imageajlittoz ( 2018-08-10 11:30:45 +0200 )edit
0

answered 2018-08-09 08:37:20 +0200

ajlittoz gravatar image

A more elaborate solution is based on "built-in" paragraph styles Numbering n, though they need first to be transformed into lists by associating a numbering style (called "list" style) to them.

The style family contains Numbering n for "standard" items, Numbering n Start for the "start" of an item series (e.g. the first of a list), Numbering 1 End for the "end" of a series (e.g. the last of a list) and Numbering n Cont. for an unnumbered item.

What specific formatting you apply to Start and End has to be defined by you.

Basically, the procedure to set the various styles is the same as the one you found out. The trick is effectively to use a space as a bullet for unnumbered list items, otherwise (no list style) your paragraph style is not considered as a list formatter by LO Writer.

The "undesirable behaviour" can be easily explained if you View>Formatting Marks. When the cursor is in the middle of the paragraph, Bksp erases characters as usual. When it is at the start (after the separator tab between the bullet/number and item text or before the bullet/number), Bksp will remove the bullet/number making an unnumbered item and a second Bksp merges the item with the preceding paragraph.

edit flag offensive delete link more
0

answered 2018-08-09 10:57:37 +0200

Lupp gravatar image

(I don't use numbring much, but what about:)
My example ask162454NumberingTwoLevels_1.odt

(Hope you see the formatting marks when opening it.)

edit flag offensive delete link more

Comments

@Lupp: simple but kind of "direct formatting" though you have a numbering_1DotaCP style which is not intrinsically fit for list. The list feature is obtained with Format>Bullets & Numbering. This is why I wouln't recommend it but for experimenting. Your procedure is vulnerable to modification to global changes whereas a specific style protects against this mis-hap.

Also, newlines don't create new paragraphs which prevents defining specific spacings for unnumbered list items.

ajlittoz gravatar imageajlittoz ( 2018-08-09 11:44:31 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-08-09 04:14:02 +0200

Seen: 44 times

Last updated: Aug 10