Ask Your Question
0

Document could not be locked

asked 2018-09-05 17:11:34 +0200

rogerg2 gravatar image

I am trying to reinstall LibreOffice (6.0.6.2.) on Windows 10.

This message keeps appearing:

"Document could not be locked The lock file could not be created for exclusive access by LibreOffice, due to missing permission to create a lock file on that file location ..."

This is followed by the option to "Open read-only" or "Cancel".

I'd appreciate any help for getting past this issue and back to editing my LibreOffice documents.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2019-03-05 03:50:16 +0200

I'm having exactly the same problem. As to your Controlled Folder Access tip I just checked.

Right now "Controlled Folder Access" is OFF. I'm supposing that's good in this case?

My only workaround is to open the doc in Read-Only mode, then do a Saveas to different filename. Tomorrow, when I attempt to reopen that different filename, the vicious cycle starts over.

For what it's worth I use other apps and don't have this problem with files edited by them: Namely Paint Shop Pro 2019, and Textpad 8.

The only major changes to my computer lately have been:

  1. Windows 10 update a few days ago.
  2. I installed and am using Directory Opus daily for the past two weeks.
edit flag offensive delete link more

Comments

robleyd gravatar imagerobleyd ( 2019-03-05 07:20:45 +0200 )edit
0

answered 2018-12-07 23:38:11 +0200

Thank-you. Disabling controlled folder access in Win 10 worked for me after 30 mins of frustration trying to save a file.

edit flag offensive delete link more
0

answered 2018-10-15 17:29:42 +0200

I've had this too. And I have fixed it but the condition I had may not be relevant in your instance. For reasons I won't bore you with I'm running Windows Defender whilst my paid for security provider sorts out a major problem with their product. The version of WD this refers to is 4.18.1809.2. In an attempt to give me greater protection, I decided to switch on Ransomeware Protection which is contained under the Virus and threat protection section of WD. I did this after I'd installed the current version of LibreOffice. Having read your original post I thought it might be something to do with LibreOffice so decided to go back. When I began to install the old version I got an error telling me that the shortcut for the desktop could not be installed because of a lack of security permissions. At this point I had forgotten that I had changed the WD settings to use ransomeware protection, but after going through all the settings found the section and switched them off (their normal state). This fixed the problem and allowed me to reinstall the current version of LibreOffice. If you have conditions of this type then switch the ransomeware protection off in Windows Defender. Hopefully this may well help.

edit flag offensive delete link more

Comments

As Brush6136 suggests, turning off "Controlled folder access" under "Ransomware Protection" in Windows 10 solves the problem.

ScientificCupboard gravatar imageScientificCupboard ( 2018-10-15 22:11:10 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-09-05 17:11:34 +0200

Seen: 819 times

Last updated: Mar 05