Document could not be locked

I am trying to reinstall LibreOffice ( on Windows 10.

This message keeps appearing:

“Document could not be locked
The lock file could not be created for exclusive access by LibreOffice, due to missing permission to create a lock file on that file location …”

This is followed by the option to “Open read-only” or “Cancel”.

I’d appreciate any help for getting past this issue and back to editing my LibreOffice documents.

I have the same thing on my Apple MacBook Air. I can save the attachment (typically a Word doc) and then re-open it with not problem. The question is: What is “Lock File”?

Thank-you. Disabling controlled folder access in Win 10 worked for me after 30 mins of frustration trying to save a file.

I’ve had this too. And I have fixed it but the condition I had may not be relevant in your instance. For reasons I won’t bore you with I’m running Windows Defender whilst my paid for security provider sorts out a major problem with their product. The version of WD this refers to is 4.18.1809.2. In an attempt to give me greater protection, I decided to switch on Ransomeware Protection which is contained under the Virus and threat protection section of WD.
I did this after I’d installed the current version of LibreOffice.
Having read your original post I thought it might be something to do with LibreOffice so decided to go back. When I began to install the old version I got an error telling me that the shortcut for the desktop could not be installed because of a lack of security permissions. At this point I had forgotten that I had changed the WD settings to use ransomeware protection, but after going through all the settings found the section and switched them off (their normal state). This fixed the problem and allowed me to reinstall the current version of LibreOffice. If you have conditions of this type then switch the ransomeware protection off in Windows Defender. Hopefully this may well help.

As Brush6136 suggests, turning off “Controlled folder access” under “Ransomware Protection” in Windows 10 solves the problem.

I’m having exactly the same problem. As to your Controlled Folder Access tip I just checked.

Right now “Controlled Folder Access” is OFF. I’m supposing that’s good in this case?

My only workaround is to open the doc in Read-Only mode, then do a Saveas to different filename. Tomorrow, when I attempt to reopen that different filename, the vicious cycle starts over.

For what it’s worth I use other apps and don’t have this problem with files edited by them:
Namely Paint Shop Pro 2019, and Textpad 8.

The only major changes to my computer lately have been:

  1. Windows 10 update a few days ago.
  2. I installed and am using Directory Opus daily for the past two weeks.

Also asked on Apache OpenOffice forum

I am having the same problem. I just upgraded to windows 10 and got the same error message. I installed the latest version (6.2) and still have the same problem. I tried turning off “controlled access folder” and it did not help. Any suggestions.

With “Controlled folder access” turned off I uninstalled version (x64). Downloaded older version (64). I was able to create a new file and saved it to OS:/FUMS. When I tried to access the file again I got the same message of “missing permission to create a lock file”. I checked the file properties and I have “full control”. This is getting very frustrating. Does anyone know how to give LibreOffice “full control” of the file or folder.

Removing the folder from the protected folder list in windows defender works. I save documents on a separate storage drive so only programs I choose make changes to that drive anyway so I’m ok with windows not protecting it.

Workaround is here LibreOffice error "...insufficient user rights" in windows 10 - #8 by eddy_lt