Ask Your Question
0

LibreOffice 6.1.2 Base value field problem

asked 2018-10-09 11:42:39 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi. Recently I have updated my L.O. version to 6.1.2 and got it to work. I'm using a database with many fields, different types to input data. Some of this fields are date, time witch are not mandatory (the value must not be entered, aka blank value). The new version of Base does not allow me to pass by this field if I don't enter value. It says "the field cannot be blank", so until this bug is fixed I have returned to previous version. What can I do to use the same database file with the new version of L.O. ? Thank you and best regards.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2018-10-09 17:03:49 +0100

Ratslinger gravatar image

Hello @archeybv,

Please do not check post as wiki when posting questions or answers. It helps no one.

What you are experiencing is the result of a Bug fix. See -> Bug #75341 which was implemented in this release you mention.

You can fix the erroneous fields by editing the form and going to the properties of the controls which you have problems with. On the Data tab, change the property Input required to No. This should resolve the problem.

In previous versions this setting wasn't working properly and you may not have set it initially to No.

edit flag offensive delete link more

Comments

I'm having the same problem except the form keeps complaining about "Input Required" on a field that is not even listed on the form (checked via the form navigator). The field does exist in the database (JDBC db as a column), but the default value is always correct and is therefore not needed on the form. Is there a way to fix this?

aghoras gravatar imageaghoras ( 2018-11-05 21:03:45 +0100 )edit

@aghoras This may be a different situation. Please ask as a new question and include such vital info as LO version, OS, database and specific connector being used and the exact error you are getting.

Ratslinger gravatar imageRatslinger ( 2018-11-05 21:12:51 +0100 )edit

Thanks @Ratslinger for the answer. Does this really mean that I have to go through all of the fields on all of my forms changing the "input required" field to "no" where appropriate? This is a mega-PITA and I'm very disappointed that the LO dev team didn't see it coming. This isn't Windows 10 you know :)

Is there an easy way of reverting to an earlier version of LO?

ptoye gravatar imageptoye ( 2018-12-15 10:44:50 +0100 )edit

@ptoye

I don't see much problem and I have many, many Base files and many forms in each - but that is me. Each sees it differently. Going to an older version is only going to prolong the change as it will be in all future versions. You can always install any previous version. There is a link on the LO download page (bottom of page - 'in the archive') for all previous versions.

Ratslinger gravatar imageRatslinger ( 2018-12-15 17:19:23 +0100 )edit

I am also having the same problem, of sorts. I upgraded to Version: 6.1.3.2 (x64). At first a couple of fields were changed to "yes" input required. I set them back to "No" and problem solved. Temporarily. Now after a couple times of use, it wants input in that field again but the field is checked to "No".

Spur52 gravatar imageSpur52 ( 2018-12-17 17:22:07 +0100 )edit

@Spur52 Have not seen this type of problem nor any reports as such. Please askas new question with specifics as to what is happening.

Ratslinger gravatar imageRatslinger ( 2018-12-17 17:56:47 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-10-09 11:42:39 +0100

Seen: 128 times

Last updated: Oct 09 '18