Ask Your Question
0

List style isn't saved with the document

asked 2019-02-07 15:47:02 +0100

ychaouche gravatar image

updated 2019-02-10 11:24:10 +0100

Dear libreoffice,

When I make changes to a list style in my document, it doesn't seem to be saved, for when I open the document again, the style is NOT applied (numbering style). Any ideas ?

EDIT Here's a screencast showing the possible bug.

Libreoffice 6.1 Linux mint 17 Qiana The document is an odt file.

edit retag flag offensive close merge delete

Comments

You should make a screenshot of what you expect list to look like and how ti looks like after reopening. This way you intrigue more people.

Kruno gravatar imageKruno ( 2019-02-07 20:18:30 +0100 )edit

@Kruno thanks for the pro-tip, the screencast is at : https://vimeo.com/316370173

ychaouche gravatar imageychaouche ( 2019-02-10 10:57:02 +0100 )edit
Lupp gravatar imageLupp ( 2019-02-10 11:57:13 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-02-10 12:29:22 +0100

ajlittoz gravatar image

The only way I found to reproduce the problem was to fiddle with the "list" toolbar button.

I first created a paragraph style with list property (linked to a built-in list style). I typed a few paragraph in the current paragraph style. I selected those paragraphs and applied my custom paragraph style with list property (like your List Contents). I then changed the numbering from the toolbar button drop-down menu.

Considering it is only an experiment, I transferred the change into the list style so that it becomes permanent. To make things more demonstrative, I chose a different numbering than the one from the button. Applied, saved, reopened.

The list displays with the toolbar formatting.

Remember that whenever you play with toolbar buttons, you create direct formatting. What is worse is that bullet/numbering changes cannot be removed with Format>Clear direct formatting. The golden rule is whenever you style your document, never use again direct formatting because there are non obvious interactions between styles and direct formatting. The first of which is precedence of D.F. over styles.

To recover from the situation:

  • select your list item paragraphs
  • apply Default Style paragraph style
  • Format>Clear direct formatting
  • make sure all toolbar button are deselected (this is mainly for the bullet and numbering buttons)
  • apply your custom style for the list

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

Great explanation thanks a million for the extra special care to write a comprehensive answere. Indeed, when I open the document and place the cursor on the liste paragraphes, the numbering toolbar is in its "active" state (it is pressed). I will try the recipe and get back to you.

ychaouche gravatar imageychaouche ( 2019-02-14 11:55:45 +0100 )edit

@ajlittoz tried your reciepe but it didn't solve my issue, screencast available here : https://vimeo.com/317228149

ychaouche gravatar imageychaouche ( 2019-02-14 12:09:45 +0100 )edit

But starting from a blank page I can confirm that working with styles from the beginning (and not with the toolbar buttons) will save the list style :) !

ychaouche gravatar imageychaouche ( 2019-02-14 12:23:43 +0100 )edit

Don't know if it is related: you modify your list style in Numbering Style tab. I don't like these tabs (and don't trust them either) because they set various parameters in the last two tabs Position and Customize which are the only ones to consider. Using the other tabs after starting customizing in the two last ones usually causes conflicts and needs retuning.

Anyway, this doesn't explain why mods are not saved.

Have you tried modifying the list style before applying the change to the paragraphs?

ajlittoz gravatar imageajlittoz ( 2019-02-14 13:08:29 +0100 )edit

Thank. You. So. Much. The problem was with the Character Style applied to the List 1 style when done through the Numbering Style tab. When done with Customizeit is persistent ! see : https://vimeo.com/317259875

ychaouche gravatar imageychaouche ( 2019-02-14 15:30:52 +0100 )edit

LO is supposed to fit beginners' and power users' needs. For the former, many shortcuts to higher features are offered, like the Numbering Style tab in list styles. Shortcuts will then set several (many?) parameters in various configuration sections to give supposed "universal" results. But as you noted, these shorcuts create a mess if you started customising your styles manually. Never mix both methods. Once you move away from direct formatting (i.e. when you begin to feel at ease with styles), play only with manual custom configuration, never again trust the shortcuts.

In case of list styles, stick with Position and Customize tabs, none other.

ajlittoz gravatar imageajlittoz ( 2019-02-14 17:36:52 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-02-07 15:47:02 +0100

Seen: 25 times

Last updated: Feb 10