Ask Your Question
0

How to fix bullets and numbering that are locked in default mode and levels do not work

asked 2019-02-09 21:57:58 +0200

Broomer gravatar image

updated 2019-02-11 00:42:07 +0200

Using the Bullets & Numbering drop down menu does not work. The result for any level selected is Default which is Level 1. The Levels cannot be adjusted or added to as well. I have attached a screen shot of the results. The only solution for using bullets and numbering is to start adding bullets, let default put in its values and then go in and manually correct these indents. C:\fakepath\Bullet number example.docx

edit retag flag offensive close merge delete

Comments

Read these guidelines and edit your question (the link with the slanted pencil below your question) to explain what you do and what you expect. Eventually provide screenshot or sample document.

ajlittoz gravatar imageajlittoz ( 2019-02-10 08:20:57 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-02-11 08:31:34 +0200

ajlittoz gravatar image

updated 2019-02-12 11:19:37 +0200

I think there are 2 design flaws in your documents.

  1. Your document is saved as .docx. Unless you have an exchange requirement, save it native as .odt because M$ Word and LO Writer are not based on the same principles and primitive. Presently you bump head first into compatibility problems. Work in .odt and convert to .doc(x) only to send the final version or send in .odt because Word is supposed to be able to read this format and reverse the blame on Word for discrepancies.
  2. I always had problems with default bullets and numbering (as they come out from toolbar button use). They are akin to direct formatting and very difficult to control or tune afterwards.

Concerning the first point, Word has no notion of character and list style and manages these concepts directly. When Writer scans the file to open it, it converts these formatting into computed equivalent styles. In your case, you have 3 list styles WWWNum1 to WWWNum3, the first of which unused in the sample document. When you modify the default list appearance with Format>Bullets & Formatting, you don't change the dedicated styles which explains why nothing happens.

Apparently, you already have some experience with styles, at least with paragraph and character categories. I then recommend you create your own list formatting based on a paragraph style (e.g.the List n or Numbering n families) associated with a list style in the Outline & Numbering tab. Take note that built-in List n and Numbering n are not associated with a list style by default, so they behave as ordinary paragraph styles until you make the association.

When your lists are properly styled, everything works as expected.

Also, all your paragraphs are in Default Style with eventually numbering/bulleting added with the toolbar button. This may be only to create the sample text, but never do it in real document: Default Style should never be routinely used; its purpose is only to define user defaults inherited by all other styles. The formatting toolbar buttons (IMHO) are there to allow for quick-and-dirty experiments not for permanent formatting of long standing documents; they create direct formatting which causes numerous "lock" situations afterwards.

EDIT 2019-2-12

Experimented with your .odt sample file with LO 6.0.6.2 without modifying your paragraph styles so that i am in the default numbering context.

  • I can add new items and a tab at the beginning changes level and bullet according to your settings
  • Tabbing and untabbing at the beginning of any item but the first changes level as expected
  • BUT, tabbing the first list item increases indent distance for all items.

Concerning the last point, I don't know if this is an intended behaviour (because I always use ad hoc styles to control every aspect of my lists). It seems to be "logical" since the first item in a list is supposed to be at the main level. Only subordinate items can be set at higher ... (more)

edit flag offensive delete link more
0

answered 2019-02-11 20:23:51 +0200

Broomer gravatar image

I redid bullet and numbering using the main template and opening in Text Body. I then typed in information and attempted to use bullets and numbering and got the same problem. I saved the file in .odt format and am attaching it for you to look at. I only used docx because the ASK help did not specify .odt as compatible for import.

C:\fakepath\Bullet number example.odt

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-02-09 21:57:58 +0200

Seen: 114 times

Last updated: Feb 12