Ask Your Question
1

How to create dual-font Impress slide master

asked 2019-07-08 01:39:59 +0200

polyhat gravatar image

updated 2019-07-09 12:47:35 +0200

I want to make a master slide that has side-by-side text boxes wherein each box has a separate font. The left box should be "Times New Roman," as it will be for the English language; and the right box should be "Saysettha MX," corresponding to the Lao translation. When I set the font in one box, however, it sets the other box to the same font. This is entirely inappropriate for this bilingual application. Is it possible to change this?

Software Details: Mac OSX 10.8.5 LibreOffice Version: 4.3.2.2

Computer: MacBook Pro, Mid 2012image description In the screenshot, notice that I have only a "Modify…" option and a "Hide" option when right clicking on the Default style.

UPDATE: I was saving it in .pptx format because I may need to transfer it to someone else's computer later for presentation, and felt that would be safer for compatibility. But I went ahead and tried the suggestion of saving it as an .odp. That messed things up. The fonts all reverted to Liberation Sans, and the layout shifted strangely. On top of that, I still have no "New" style option in the right-click menu for styles. See below.image description

UPDATE II: I decided to try upgrading my LibreOffice. It didn't end well. The newest version of LO claimed to be compatible with my OS, but, after downloading ~250 MB in an hour plus, I discovered my OS was too old. I went to an earlier version; same story. I went to an earlier version yet, same story. After three such downloads, I've learned that LO documentation is totally unreliable. I finally went back to a version not much newer than what I have (from 2016?), and it worked on my computer. BUT, it still did not give me a "New" option for the styles, AND, it destroyed the master slide interface completely, leaving only one possible slide to edit--even if that was NOT the slide actually used in the document. So, as seems commonplace nowadays, the "upgrade" was actually a "downgrade." I'm about ready to throw in the towel. I think I've embarked on an impossible wild goose chase.

A word to the would-be LibreOffice user: It appears that presentation styles for the master slide can only be monolingual. For polyglots, tough luck.

UPDATE III: I think I have attached the file here, nothing fancy, and I'm not sure how it can help to resolve the issues, but would be very glad if indeed there is a solution.

edit retag flag offensive close merge delete

Comments

The answer provided by "ebot" below does not fit my case. Perhaps it is on account of a Windows vs. Mac issue, but I have no "new" option after right clicking on "default" in the second window. This is, in fact, the very crux of my issue and the reason for my question, as I was attempting to set each auto layout window up with its own font and was unable. Modifications in one window automagically update the other so that they are lockstep in tandem, and cannot be different. I appreciate the effort it took to answer, though. Thank you for trying.

polyhat gravatar imagepolyhat ( 2019-07-08 10:08:14 +0200 )edit

The cursor must be in the text, not on the edge of the text box. And why now two windows?

ebot gravatar imageebot ( 2019-07-08 10:27:53 +0200 )edit

I wish I could put up a picture so you could see it. I am using the slide format that has one title box at the top, under which are two boxes side by side for content, whether text, an image, etc. I want to use a different language in each box, so I need a different font for each. If I use the Saysettha font for English, it puts far too much space between lines. The English font will not even render the Lao properly. It looks like I'll be stuck with what looks like double-spaced English text beside single-spaced Lao--but then I will still have a problem, because I don't want the English box to be wider to accommodate this. It seems quite odd that LO has to marry the windows like this and does not allow them to have separate styles applied to each.

polyhat gravatar imagepolyhat ( 2019-07-08 11:11:13 +0200 )edit

I have assigned you a little karma. Now you should be able to upload a screenshot. Edit your question, there you can insert a picture.

ebot gravatar imageebot ( 2019-07-08 11:15:15 +0200 )edit

As you've probably read, I use Windows OS. But I can not imagine that the functions are treated differently in the OS. So I would try to reset the user profile. Do not forget to save the existing profile first.

ebot gravatar imageebot ( 2019-07-08 11:38:24 +0200 )edit

Ahhh, i have seen you have a pptx file. This can cause problems. There is no 1 to 1 functionality between M$ and LO. Try saving your file as ODP file. Then check if you can create a new style.

ebot gravatar imageebot ( 2019-07-08 12:18:02 +0200 )edit

I forgot to mention in my update above that I also managed to clear the user settings and start fresh with automatically generated ones, but this did not change the problem. (It changed a few other things.) I reckon I'll revert to the old user profile, as it seems not to have been the problem.

polyhat gravatar imagepolyhat ( 2019-07-08 19:13:43 +0200 )edit

Would it be possible that you upload your file here? Edit your initial question and select the icon for attachment.

ebot gravatar imageebot ( 2019-07-09 09:28:51 +0200 )edit

I guess it's not possible. I had used four images for the first four slides, and even though I deleted three of them, leaving only the first slide, and even though I had only a single slide with text in it, it kept the old file size of 1.8 MB. The limit here seems to be 1 MB. I saved the reduced file under a separate file name, but it still left the file size unchanged. The more I learn about this software, the more nonplussed I become. By the way, I am now working from the following version, after having upgraded slightly:

Version: 4.4.7.2 Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600 Locale: en.UTF-8

polyhat gravatar imagepolyhat ( 2019-07-09 12:04:09 +0200 )edit

You can remove all the pictures, it's only about the text in different fonts.

ebot gravatar imageebot ( 2019-07-09 12:15:15 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-07-08 09:38:50 +0200

ebot gravatar image

updated 2019-07-08 09:45:57 +0200

1.) Each paragraph has a style. As long as the style is the same for all paragraphs, the fonts are the same. Place your cursor in the left text box. Select styles in the sidebar F11. The style "Default" is displayed.

image description

Right click on "Default" and select Modify .... For example, if you want to change the font size for Times New Roman, you can specify it here.

image description

Click OK.

2.) Put your cursor in the right text box. Right click on style "Default" and select New .... Give the new style a name (at "Organizer", like "My new font").

image description

Choose the font and size and click OK.

image description

Finished!

image description

Maybe you should clear your entire text beforehand. Mark the text and in the menu with Format>Clear Direct Formatting.

image description

My test file.

If my answer has solved your problem, please click on the checkmark ✓ in the circle image description to the left of the answer and click on the arrow ^ for upvote. This will tell the community that the question has been answered correctly.

edit flag offensive delete link more

Comments

With me Windows 10 Home; Version 1903; 64-Bit | LibreOffice, Version: 6.2.5.2 (x64).

ebot gravatar imageebot ( 2019-07-08 09:39:16 +0200 )edit

An example of how styles are created can be found here.

ebot gravatar imageebot ( 2019-07-08 09:48:40 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-07-08 01:39:59 +0200

Seen: 41 times

Last updated: Jul 09