Ask Your Question

Table column width changes after saving + closing

asked 2019-08-19 10:19:36 +0200

ManderW gravatar image

updated 2019-08-19 14:33:06 +0200

I have several tables with different column widths in my document. When I save the document, close the file, and reopen it, the column widths have reset to be equally spaced. What is going on?

LibreOffice Writer (x64) on Windows 10

Edit: I have attached a sample file. When I created the tables, I set them to the following: Centre Width 18 cm First table columns: 7.2 and 10.8 cm Second table columns: 3.5 and 14.5 cm Left justified

I saved the document, closed it, and when I opened it again the tables were set to automatic and evenly spaced columns.C:\fakepath\TableProblem.odt

edit retag flag offensive close merge delete


In what format are you saving the document - native ODF or some other?

robleyd gravatar imagerobleyd ( 2019-08-19 11:03:21 +0200 )edit

Whoops, I should have mentioned that! It's native ODF, created in LibreOffice from scratch.

ManderW gravatar imageManderW ( 2019-08-19 12:22:34 +0200 )edit

Probably the table property "Alignment" is set to "Automatic" - see Table -> Properties -> Tab: Table or right click Table Properties -> Tab: Table while in table.

Opaque gravatar imageOpaque ( 2019-08-19 12:32:32 +0200 )edit

I checked this originally and just went though and double-checked it. The alignment is set to center, with an absolute table and column width. But as soon as I save it and close it the table properties that I set are lost.

ManderW gravatar imageManderW ( 2019-08-19 13:28:02 +0200 )edit

Could you upload an anonymized sample file showing the effect?

Opaque gravatar imageOpaque ( 2019-08-19 13:37:18 +0200 )edit

I edited the original post to attach a sample file.

ManderW gravatar imageManderW ( 2019-08-19 17:11:49 +0200 )edit

Whatever happens here, this is far beyond my understanding. You even may delete everything, add a new table and make any settings, it gets resetted to evenly distributed columns on reload. From my perspective the file is completely messed up, since this doesn't happen on new files.

Update Finally it turned out that file settings.xml within the zip container (=.odt file) causes the problem. Will write an answer, if I've found the exact entry (for testing purposes, I've deleted a bunch of entries, just to see whether it has an effect. Now trying to find the correct one).

Opaque gravatar imageOpaque ( 2019-08-19 17:41:00 +0200 )edit

1 Answer

Sort by » oldest newest most voted

answered 2019-08-19 20:00:44 +0200

Opaque gravatar image

updated 2019-08-19 23:02:10 +0200


the following entry in file settings.xlm causes your issue:

<config:config-item config:name="EmbedOnlyUsedFonts" config:type="boolean">true</config:config-item>

Don't ask me why, but this is definitely the cause. Please see a modifiation of your file, which doesn't contain that entry any longer and thus your table could be defined the way you want 'em


Note To fix this from within LibreOffice untick File -> Properties -> Tab: Font -> Cat: Font embedding -> Option: Only embed fonts that are used in documents

If the answer is correct or helped you to fix your problem, please click the check mark (✔) next to the answer.

edit flag offensive delete link more


Note Until now I found now way to configure this from within LibreOffice.

See FilePropertiesFont tab.

Hopefully OP will file a bug report...

Mike Kaganski gravatar imageMike Kaganski ( 2019-08-19 20:07:03 +0200 )edit

@Mike Kaganski - Updated while you commented. Sorry for the overlapping.

Opaque gravatar imageOpaque ( 2019-08-19 20:08:48 +0200 )edit

Wow, thanks for figuring this out! I would never have known to even look there. I remember checking that option the other day when I was exporting the original document to a PDF, thinking that it would ensure that whatever fonts I was using would render properly.

Are there some idiot friendly instructions for filing a bug report somewhere?

ManderW gravatar imageManderW ( 2019-08-19 22:24:46 +0200 )edit

Have filed bug report #tdf127036. You may add any comments at your discretion.

Opaque gravatar imageOpaque ( 2019-08-19 22:58:47 +0200 )edit

Great, thanks for doing that!

ManderW gravatar imageManderW ( 2019-08-20 12:44:39 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2019-08-19 10:19:36 +0200

Seen: 39 times

Last updated: Aug 19