Ask Your Question
0

how can I modify the default bullet style in Text Body style [closed]

asked 2013-07-22 14:38:58 +0200

ROSt52 gravatar image

updated 2013-07-22 14:39:39 +0200

When I write a document I typically work with Text body style, which I could adjust to my needs. Whenever I need a bullet list I use ctrl+shift+B creates a bullet list. How can I modify this bullet list so that I have the modified bullet list as my default.

Looking the Text body style window I only can see:

image description

I am very grateful for any hint on how to modify this default style.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-05 18:39:19.451429

3 Answers

Sort by » oldest newest most voted
1

answered 2013-07-25 09:42:15 +0200

oweng gravatar image

@ROSt52, presumably your CTRL+SHIFT+B key assignment is used to replace the default SHIFT+F12, which is the Function for "Bullets On/Off" i.e., the same as clicking on the toolbar equivalent. This will always give you the vector object shown in the first box under Format > Bullets and Numbering... > Bullets tab.

The best way around this problem (as @mariosv suggests) is to use the List 1 paragraph style. First ensure the List 1 paragraph style is tied to the List 1 list style i.e., right-click on the List 1 paragraph style > Modify... > Outline & Numbering tab > Numbering section > set the Numbering Style to "List 1". Then edit the List 1 list style and give it your required vector graphic object as a bullet i.e., right-click on the List 1 list style > Modify... > on the Bullets tab or Graphics tab select an alternate bullet style. Lastly assign the List 1 paragraph style to a key combination via Tools > Options... > Keyboard tab > Category of "Styles > Paragraph" and Function of List 1.

edit flag offensive delete link more
1

answered 2013-07-23 00:29:18 +0200

m.a.riosv gravatar image

updated 2013-07-23 00:29:39 +0200

Hi ROSt52, I do not use it too much, but I think you are looking for the last left icons in the styles in F11. (I can not upload now an image, doesn't work).

edit flag offensive delete link more
0

answered 2013-08-03 04:29:43 +0200

ROSt52 gravatar image

@mariosv and @oweng - Thanks for the help form both of you.

While reading the answer of @oweng I got the feeling this is for me an important part to understand connections between styles.

Will the change @oweng described for List1 also change the the top most left style in the window

image description

edit flag offensive delete link more

Comments

Unfortunately no. Creating a new style will simply allow you to select from the existing boxes (bullet styles). I asked a question about custom bullet graphics some time ago: http://en.libreofficeforum.org/node/2280 There is no elegant solution to altering the available options. I believe the definitions are stored in /opt/libreoffice4.1/shared/gallery somewhere (probably symbols.sdg, which is a StarOffice Gallery file or one of the other SDGs).

oweng gravatar imageoweng ( 2013-08-03 07:18:04 +0200 )edit

@oweng - Thanks for above comment. I expected it, but still dared to ask.--- Following your explanations I could assign a new bullet to List1 and could assign this to ctrl;shift+B. However than the toggle functionality (bullets on/off) gets lost.--- I tried all kind of possibilities but could not replace the default bullet which is shown in my original question.---

ROSt52 gravatar imageROSt52 ( 2013-08-03 13:57:31 +0200 )edit

part 2 --- Now I created a new List style with the bullets and assigned it to a short cut key; this unfortunately doesn't toggle, hoever it switches the bullets on. Thus I use ctrl;shift+B as the toggle switcht to switsch of my customized bullets.So far a workaround I can live with.----

ROSt52 gravatar imageROSt52 ( 2013-08-03 13:57:51 +0200 )edit

part 3 --- I also observed an unusual behavior which I could neither analyze nor repeat. ctrl+shift+B worked as a toggle switch between on -> the standard bullets -> my customized bullets -> off. I saw this already in a 3.6 version an thought (very happily!!!) that this is now stored in my saved file and template. However opening the file and template this nice functionality was gone. I will try to make attempts again and log my actions hopeing this can lead to more understanding.

ROSt52 gravatar imageROSt52 ( 2013-08-03 13:58:26 +0200 )edit

You can't toggle a style, you can only assign it, thus one shortcut for List 1 style, another shortcut for Text body (or clear formatting).

oweng gravatar imageoweng ( 2013-08-03 14:39:51 +0200 )edit
  1. Open the template for the document.
  2. In the template, click somewhere that uses the style you want to set the default type of bullet or numbering for (e.g. 'Text Body').
  3. Styles menu -> Edit Style -> Numbering.
  4. In the Numbering / Numbering Style: dropdown box, choose a numbering style (e.g. 'Numbering 1')
  5. Next to that drop-down box, click 'Edit Style'
  6. 'Outline' tab -> choose preferred type of outline numbering. Same for other tabs ('Bullets', 'Image' etc.) Done!
RodS gravatar imageRodS ( 2017-05-25 11:53:40 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2013-07-22 14:38:58 +0200

Seen: 9,426 times

Last updated: Aug 03 '13