Ask Your Question

Any way to disable 'adjust row height'? Bug?

asked 2019-09-05 00:16:52 +0200

anonymi gravatar image

In a largish spreadsheet with wrapped text, there is a significant delay on selecting any cell while the program automatically 'adjusts row height' , even though no changes have been made to content.

Disabling text wrap removes the problem, but the nature of the spreadsheet needs large blocks of text to be worked with, so that is impractical Is there any way to disable this function? Is it a bug that its taking up so much time to constantly calculate the heights?

The lag is getting so bad that its becoming impossible to work!

edit retag flag offensive close merge delete


What are your PC specs?

lazarus477 gravatar imagelazarus477 ( 2019-09-05 04:31:53 +0200 )edit

Core i5 2.3 GHz, 4gb Ram, Win 7, Nvidia GT540M 1GB. Not the most up to date but handles most things I throw at it pretty well. Seems crazy that its struggling with a relatively simple spreadsheet

anonymi gravatar imageanonymi ( 2019-09-05 15:08:13 +0200 )edit

Note that performance issues are also kind of issues that should be reported (in a way that allows reliable reproduction), and fixed.

Mike Kaganski gravatar imageMike Kaganski ( 2019-09-06 07:28:12 +0200 )edit

Your PC specs look perfectly good, unless your spreadsheet is a beast, is it? How large is the file?

lazarus477 gravatar imagelazarus477 ( 2019-09-08 06:51:24 +0200 )edit

The original question was how to disable adjust row height. It was not a question about performance. Could you please answer the original question? Thank you very much!

powercraft gravatar imagepowercraft ( 2020-06-30 14:28:00 +0200 )edit

@powercraft: if you care to notice, there comments were posted as comments, not as answers. If those who commented felt it's irrelevant, they wouldn't comment (and if you look closely, the question contained performance concerns). If they thought they were answering, they would post it as answer. If they knew the answer to the direct question, then they would post that. Please refrain from useless notes. Looks like you demand something.

Mike Kaganski gravatar imageMike Kaganski ( 2020-06-30 15:08:43 +0200 )edit

Hi everyone,

I would just like to suggest that this "adapting row height" sub-routine is perhaps past its "sell by" date. It's incomprehensibly obstructive. The solutions proposed with this topic are at best a compromise.

There will be rapture and jubilation when the cursed thing is removed / re-written / replaced / disabled.

Thank you.

mrjjacobs gravatar imagemrjjacobs ( 2021-02-18 10:28:35 +0200 )edit

2 Answers

Sort by » oldest newest most voted

answered 2020-06-30 15:22:26 +0200

Ok, found a solution to disable Adapt Row Height. Format - Clear Direct Formatting.

Select all and then simply press Ctrl+M. It removes direct formatting.

Nothing to do with computer performance at all. Just as the original poster described - a deliberate "bug" made by the devs :)

edit flag offensive delete link more


Sigh. Another ... ignorant person declaring deliberate wrongdoing.

I realize that reading is hard - but would you be so kind to read my initial comment to the question? Have you reported your findings to the bug tracker? or are you only good in accusations?

Mike Kaganski gravatar imageMike Kaganski ( 2020-06-30 15:26:56 +0200 )edit

Haha, bad mood today? The question was how to disable adapt row height and I answered the question. Where is the problem? The word "bug" I put in quotes because I said it figuratively and it's not a software bug. It's simply functionality that some people find annoying and very few people are using. Hence the quotes around "bug". No need to add it to the bug tracker, thanks.

powercraft gravatar imagepowercraft ( 2020-07-01 00:08:26 +0200 )edit

bad mood today?

Yes, it really seemed to be the day when I better shut up. Sorry.

Mike Kaganski gravatar imageMike Kaganski ( 2020-07-01 00:28:16 +0200 )edit

answered 2019-09-05 04:30:07 +0200

lazarus477 gravatar image

updated 2019-09-05 04:31:38 +0200

I doubt that it is a bug in LO. More likely it is a performance issue. It could be due to a lack of optimizing the code that is involved in the calculations of row heights. It can also be a result of your computer running into a bottle neck.

Things to consider:

  • CPU
  • RAM
  • GPU

LO is a quite heavy application. As software grows in complexity and users want to compute ever vaster amounts of data our computers need to keep pace in processing speed. Sometimes simply upgrading RAM or GPU is enough. Also having a properly working graphics card driver is important as some calculations take place in the GPU, such as OpenGL. GPU accelerated software is also a thing today but I am not sure if LO makes use of this.

edit flag offensive delete link more


Could you answer the question that was asked please?

powercraft gravatar imagepowercraft ( 2020-06-30 14:28:25 +0200 )edit
Login/Signup to Answer

Question Tools



Asked: 2019-09-05 00:16:52 +0200

Seen: 633 times

Last updated: Jun 30 '20