Any way to disable 'adjust row height'? Bug?

In a largish spreadsheet with wrapped text, there is a significant delay on selecting any cell while the program automatically ‘adjusts row height’ , even though no changes have been made to content.

Disabling text wrap removes the problem, but the nature of the spreadsheet needs large blocks of text to be worked with, so that is impractical
Is there any way to disable this function? Is it a bug that its taking up so much time to constantly calculate the heights?

The lag is getting so bad that its becoming impossible to work!

What are your PC specs?

Core i5 2.3 GHz, 4gb Ram, Win 7, Nvidia GT540M 1GB.
Not the most up to date but handles most things I throw at it pretty well. Seems crazy that its struggling with a relatively simple spreadsheet

Note that performance issues are also kind of issues that should be reported (in a way that allows reliable reproduction), and fixed.

Your PC specs look perfectly good, unless your spreadsheet is a beast, is it? How large is the file?

The original question was how to disable adjust row height. It was not a question about performance. Could you please answer the original question? Thank you very much!

@powercraft: if you care to notice, there comments were posted as comments, not as answers. If those who commented felt it’s irrelevant, they wouldn’t comment (and if you look closely, the question contained performance concerns). If they thought they were answering, they would post it as answer. If they knew the answer to the direct question, then they would post that. Please refrain from useless notes. Looks like you demand something.

Hi everyone,

I would just like to suggest that this “adapting row height” sub-routine is perhaps past its “sell by” date. It’s incomprehensibly obstructive. The solutions proposed with this topic are at best a compromise.

There will be rapture and jubilation when the cursed thing is removed / re-written / replaced / disabled.

Thank you.

I doubt that it is a bug in LO. More likely it is a performance issue. It could be due to a lack of optimizing the code that is involved in the calculations of row heights. It can also be a result of your computer running into a bottle neck.

Things to consider:

  • CPU
  • RAM
  • GPU

LO is a quite heavy application. As software grows in complexity and users want to compute ever vaster amounts of data our computers need to keep pace in processing speed. Sometimes simply upgrading RAM or GPU is enough. Also having a properly working graphics card driver is important as some calculations take place in the GPU, such as OpenGL. GPU accelerated software is also a thing today but I am not sure if LO makes use of this.

Could you answer the question that was asked please?

I am having the same issue and perhaps can add some light. Just upgraded to 7.05.02
OSX 10.13 (stuck there until another vendor fixes some issues)
Mac Late 2013 Intel i7 2.66 GHz, 16 Gb 1600 MHz DDRAM NVIDIA GeForce GT 750M 2048Mb

Initially, the spreadsheet loaded very quickly. Then we’re back to the OP’s issue, adjusting row height.
Two things were done that started the adjusting row height: Change in SS mag factor to 75%
python update to a value table using the following python libraries:
import ezodf
from ezodf import newdoc, Sheet

ezodf is maintained by the python excel team but it’s the best I could find at the time I wrote it. The SS is big. the Python routine is standalone, reads a values table from one of the sheets, imports values and re-writes that page’s cells with updated values. Two things then happen: LO Calc treats these as non-numeric fields until a copy/paste is performed. Annoying but an easy fix, and the “adjusting row height” issue slowness.

Ok, found a solution to disable Adapt Row Height. Format - Clear Direct Formatting.

Select all and then simply press Ctrl+M. It removes direct formatting.

Nothing to do with computer performance at all. Just as the original poster described - a deliberate “bug” made by the devs :slight_smile:

Sigh. Another … ignorant person declaring deliberate wrongdoing.

I realize that reading is hard - but would you be so kind to read my initial comment to the question? Have you reported your findings to the bug tracker? or are you only good in accusations?

Haha, bad mood today? The question was how to disable adapt row height and I answered the question. Where is the problem? The word “bug” I put in quotes because I said it figuratively and it’s not a software bug. It’s simply functionality that some people find annoying and very few people are using. Hence the quotes around “bug”. No need to add it to the bug tracker, thanks.

bad mood today?

Yes, it really seemed to be the day when I better shut up. Sorry.