Ask Your Question
0

Autocorrect apply not smartening quotation marks

asked 2019-10-16 11:11:06 +0100

Chris Vella gravatar image

updated 2019-10-16 17:15:19 +0100

I tried to use the autocorrect apply feature from the menu particularly to smarten apostrophes and quotations marks, but it is not working. The language is English UK, and the paragraph style is Default.

EDIT

I tried to select the text, choose Tools, Autocorrect, Apply to turn straight apostrophe and quotation marks into twisted ones. Examples:

it's → It’s; "Lorem Ipsum" → “Lorem ipsum”
Autocorrect works properly while typing replacing the straight marks to typographic ones, but not when applied later.

EDIT 2

These are the Autocorrect, localised options: image description

edit retag flag offensive close merge delete

Comments

Read these guidelines and ask a good question. In particular:

  1. What do you mean under to smarten apostrophes and quotations marks?
  2. What exactly did you try?
  3. What did you want to achieve?
  4. What is not working?

Also, share a sample file.

gabix gravatar imagegabix ( 2019-10-16 11:26:03 +0100 )edit

I tried to select the text, choose Tools, Autocorrect, Apply to turn straight apostrophe and quotation marks into twisted ones. Example: it's → It’s; "Lorem Ipsum" → “Lorem ipsum”.

Chris Vella gravatar imageChris Vella ( 2019-10-16 12:23:07 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-10-16 13:36:40 +0100

gabix gravatar image

In the Autocorrect options window (Tools or Edit → Autocorrect → Autocorrect options), go to the Localized options tab and check if the desired replacement options are enabled for single/double quotes for your language. Modify as necessary.

edit flag offensive delete link more

Comments

See my edited question.

Chris Vella gravatar imageChris Vella ( 2019-10-16 15:00:52 +0100 )edit

Your edit does not have sufficient information. What are the settings in the tab that I have mentioned in my answer?

gabix gravatar imagegabix ( 2019-10-16 16:29:11 +0100 )edit

Instead of the defaults, set the desired replacement options explicitly.

gabix gravatar imagegabix ( 2019-10-16 17:47:14 +0100 )edit

That did the trick, but why on earth does the same setting function in one way when typing and in another when applied in retrospect? Sounds like a bug to me.

Chris Vella gravatar imageChris Vella ( 2019-10-16 21:56:14 +0100 )edit

Well, at least, inconsistent behavior. You can file an RFE.

gabix gravatar imagegabix ( 2019-10-17 09:32:43 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-10-16 11:11:06 +0100

Seen: 47 times

Last updated: Oct 16