Ask Your Question
0

Top menu bar stretched and wonky looking? [closed]

asked 2013-08-15 17:35:52 +0200

venn177 gravatar image

updated 2015-11-07 04:03:12 +0200

Alex Kemp gravatar image

Everything in the top bar is stretched and weird looking, here's a screenshot:

http://puu.sh/42MCI.png

It's been like this since version 3.5. At one point I just ignored it but I've been working on a huge project in the last couple of weeks and it's been driving me up a wall. On Windows 7 64-bit.

Edit: Here's a more complete screenshot: http://puu.sh/43UKX.png

Edit2: I should mention there's tons of that stretched whitespace in everything, not just Writer.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-07 04:03:36.635601

Comments

Did you try to change some options in Option -> Tools -> and then LibreOffice -> View... maybe if you change iconsize to small this will not happen. Also, there is option: scaling.

Ljiljan gravatar imageLjiljan ( 2013-08-16 10:46:39 +0200 )edit

The padding around everything is still there. For the sake of completeness, here's a screenshot of a complete new document: http://puu.sh/43UKX.png

venn177 gravatar imagevenn177 ( 2013-08-17 14:10:38 +0200 )edit

This is really rare case of such behaviour; I've never seen something similar. Maybe you should write as much information as possible about your system and LibreOffice version (exact version) in order to find out possible cause of this behviour... can you try "portable" latest LibreOffice version, to see if there is any change? http://www.libreoffice.org/download/portable/ You just download it and run it directly from folder.

Ljiljan gravatar imageLjiljan ( 2013-08-17 16:13:16 +0200 )edit

I'm not sure what other system information I can post. Windows 7 64-bit, AMD processor, AMD video cards. It's the newest version of LibreOffice (although I also tried 4.0 and 3.5.6, I believe).

The portable version has the same issue.

Edit: I also attempted to remove everything LibreOffice-related and reinstall it all. Again, did nothing.

venn177 gravatar imagevenn177 ( 2013-08-17 18:04:35 +0200 )edit

Take a look at these http://en.libreofficeforum.org/node/216 (interesting discussion, related to your problem). "This is happening due to using a custom Windows XP theme. I solved my problem by using a different theme"... I guess the same issue could be in Windows 7.

Ljiljan gravatar imageLjiljan ( 2013-08-18 11:52:50 +0200 )edit
1

Good lord. IT IS FIXED. Disabling visual styles removes all the flavor of it, but it's fine and is once again usable.

venn177 gravatar imagevenn177 ( 2013-08-20 22:21:40 +0200 )edit

Great! :) I am really happy that you solved it. I know how such things can irritate.

Ljiljan gravatar imageLjiljan ( 2013-08-21 08:57:39 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2013-08-18 11:54:20 +0200

Ljiljan gravatar image

updated 2013-08-21 17:53:28 +0200

"As a workaround which doesn't require you to discard the custom style, right click on each of the Libre Office components' shortcut, choose "Properties", go under the "Compatibility" tab and tick "Disable Visual Styles"

edit flag offensive delete link more
2

answered 2013-08-20 22:22:41 +0200

venn177 gravatar image

THANKS TO LJIJAN for his incredible patience and help in finding the answer and razon_22 for actually figuring out the issue. Here's the fix:

"Also, try this (from the link at the previous comment): "As a workaround which doesn't require you to discard the custom style, right click on each of the Libre Office components' shortcut, choose "Properties", go under the "Compatibility" tab and tick "Disable Visual Styles""

edit flag offensive delete link more

Comments

It would be good idea to mark this post as the correct answer...

Ljiljan gravatar imageLjiljan ( 2013-08-21 10:01:46 +0200 )edit

I would but it doesn't allow me to mark my own posts as the answer. Says I need more "points."

venn177 gravatar imagevenn177 ( 2013-08-21 16:37:48 +0200 )edit

Ok. I converted my comment to answer, so this question could be marked as "answered" :)

Ljiljan gravatar imageLjiljan ( 2013-08-21 17:54:27 +0200 )edit
0

answered 2013-08-15 23:55:14 +0200

razon_22 gravatar image

updated 2013-08-15 23:58:49 +0200

Close LibreOffice. Go to your appdata directory: \AppData\Roaming\ Cut the LibreOffice folder and paste it in a temporary directory outside of the appdata folders. Don't completely delete it. Start LibreOffice.

This should resolve your issue. If you would like further reading about toolbar issues resulting from migrations, see http://ask.libreoffice.org/en/question/19167/toolbar-icons-messed-up-during-migration-366-to-403/

edit flag offensive delete link more

Comments

Nope, didn't fix it. Still looks the exact same.

venn177 gravatar imagevenn177 ( 2013-08-16 06:47:05 +0200 )edit

Have you tried to change toolbar themes and/or use large icons on the toolbar?

razon_22 gravatar imagerazon_22 ( 2013-08-16 19:48:40 +0200 )edit

Neither of those affected the stretched menu or padding around the toolbars at all.

venn177 gravatar imagevenn177 ( 2013-08-17 14:09:49 +0200 )edit

What version of LibreOffice are you using? Have you changed the Win7 theme from the default theme?

razon_22 gravatar imagerazon_22 ( 2013-08-17 17:39:28 +0200 )edit

Actually... yes. I am using a custom Windows 7 theme. As far as I know it's just visual without any actual changes otherwise. But I'm thinking that could be it.

Of course, changing it back would be a massive pain in the ass, so I can't really confirm, I don't think.

venn177 gravatar imagevenn177 ( 2013-08-17 18:15:28 +0200 )edit

It is possible to save your custom theme, then switch back to the default and see if that fixes it.

razon_22 gravatar imagerazon_22 ( 2013-08-18 04:32:18 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2013-08-15 17:35:52 +0200

Seen: 596 times

Last updated: Aug 21 '13