Ask Your Question
0

LibreOffice Runs Slow

asked 2020-06-10 05:12:30 +0100

Yonkers gravatar image

updated 2020-08-05 12:28:47 +0100

Alex Kemp gravatar image

I am trying to complete an assignment on Libreoffice. Every time I open an already saved file or a new file it runs so slow I cannot work. Typing is delayed by multiple seconds as well as most things. It is my only application that runs slow. Any help would be appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2020-06-10 07:35:22 +0100

blashrkh gravatar image

There are a number of things to check. You should ideally restart your system after applying troubleshooting step and before launching libreoffice to see if it worked. LibreOffice runs in the background and GPU configuration software differs in implementation so the most effective and quickest way to troubleshoot is to actually restart after making changes in each step.

  1. ensure that you have the latest drivers for your GPU.

  2. try running LibreOffice in safe mode to rule out any extensions, templates, macros, dictionaries are causing the problem. (goto the Help menu, then select restart in safe mode). There are a number of options there and you should ideally have none of them checked/enabled. Leave resetting your LibreOffice user profile until step 7. You might also take this opportunity to backup your user profile - there is a button which appears upon safe mode launch).

    If performance is fine in safe mode then you know it is probably a setting within LibreOffice somewhere that is degrading performance.

  3. Try toggling OpenCL within LibreOffice to its opposite value. "Tools" / "Options" / "LibreOffice" / "OpenCL" / OpenCL" then restart your system. Also try toggling Java integration.
    Also, try modifying the options in Menu/Options/LibreOffice/View/Graphics Output/. Includes use hardware acceleration, anti-aliasing, openGL for all rendering, ignore OpenGL blacklist. Try all of these four options off (not checked) first. Failing that there may be up to 4x4=16 combinations for these 4 options so you might try each individually.

  4. Try setting your windows pagefile size to zero. Via start->run->sysdm.cpl Advanced->Settings->Advanced tab and select change button then set to zero page file size. You will need to restart windows.

    Paging is the effective transfer of working RAM memory to disk if you have too many applications open in order to "hibernate" applications with allocated memory but not actively being used. Given disk is a slow memory storage you want to minimise how many apps you have open.

    Switch off the page / set the page file to zero as a temporary test to see if access to free RAM may be an issue. Even if you have RAM available it is worth doing to see if it also has an impact on general windows performance.

  5. use the GPU software configuration bloatware to configure your system such that it is NOT utilising your GPU. The quickest test might involve just switching all forms / options of GPU processing across the system. Eg, AntiAliasing, Vertical refresh, OpenGL Triple Buffering, etc disabling all options then restarting your machine to see if it is the GPU configuration that is impacting performance. The goal here is to switch off all forms of GPU processing as a test. If successfully speeds things up you can then selectively switch items back on again. Unfortunately it is possible that not all options may be configured under an "application profile" in your graphics configuration utility and therefore may need to disable graphics options which may affect the whole system. So as a quick test it is recommended to ...
(more)
edit flag offensive delete link more

Comments

Wow thank you so much! I'll start trying this now.

Yonkers gravatar imageYonkers ( 2020-06-15 00:26:22 +0100 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2020-06-10 05:12:30 +0100

Seen: 737 times

Last updated: Jun 10 '20